Options

Foreign characters in mail body

peterke1974peterke1974 Member Posts: 23
Hello,

I need to send mails in foreign languages. I use SMTP for this
When I add text to the body (appendbody) the special characters are transformed into questionmarks.

"Mit freundlichen Grüßen" Is tranformed into "Mit freundlichen Gr??en,"

I allready tried using asciiTOansii, but that doesn't help.
ExportcodePageconvert gives the same result.

When I export the text to a text file, the text is OK when I use asciitoansii.

Anyone a solution?

Peter

Answers

  • Options
    peterke1974peterke1974 Member Posts: 23
    Nobody a solution?
  • Options
    ppavukppavuk Member Posts: 334
    Try tu use HTML body and convert foreign characters to html tags, like &szlig instead of ß.
  • Options
    FDickschatFDickschat Member Posts: 380
    This is an error in the mail.dll
    http://support.microsoft.com/kb/2516144/de
    Frank Dickschat
    FD Consulting
  • Options
    ppavukppavuk Member Posts: 334
    Thanks, did not know that hotfix available for this.
    Topic starter - please mark this as solved.
  • Options
    peterke1974peterke1974 Member Posts: 23
    Hotfix is indeed the solution. Thanx a lot
    3 Small Remarks for others:
    - In the mail.send, there is a new option enableSSL
    - In the mail.send the options are switched from position.
    - The biggest change: The dll is called Microsoft Navision mail again, instead of Microsoft Dynamics Nav mail helper (7.0)
  • Options
    FDickschatFDickschat Member Posts: 380
    Hotfix is indeed the solution. Thanx a lot
    :thumbsup:
    - In the mail.send the options are switched from position.
    Yes, you need to replace the dll on all machines at the same time as you need to recompile CU397.

    Btw, the error with foreign characters was introduced when they fixed another problem in the mail.dll earlier: The mail.dll did keep attachments open after the mail was created. It was not possible to move attachments after a mail was generated.
    Frank Dickschat
    FD Consulting
Sign In or Register to comment.