Options

Japanese characters in Navision database

supportnavsupportnav Member Posts: 34
hi all,

i am trying to import Japanese (Kanji) characters in navision database through data port.

1. After changing the System Locale to Japanese, i am able to see some Japanese chars in navision database but its different which i imported from text file. ( i mean imported .txt file and navision data are totally different).

2.Also the same if am exporting from navision using same dataport , its showing correct data in .txt file which i tried to import earlier.

ex:
imported char like: タ
Navision Data : 法人 (its displaying chars in JAP but differently, if u not able to view ,it might browser problm)
Exported data : タ

3.If am trying to copy some characters to Navison db its working.
I mean, copy paste from .txt file to Navision database its working fine.

used Database : Nav 2009 SP1 w1, SQL Server 2008 R2

pls guide me

Comments

  • Options
    ara3nara3n Member Posts: 9,256
    did you import the data after changing system local settings in windows or before?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    supportnavsupportnav Member Posts: 34
    ara3n wrote:
    did you import the data after changing system local settings in windows or before?

    thx.

    s, after changing the local settings only. Before that i cant view JAP characters in Nav DB.

    Settings done like this ..
    Control Panel --> regional & language setting --> Language for non-unicode programs to JAPANESE.

    DB settings : removed(unselected) Validate Collation option in DB's Alter settings..

    tried in Win7 and Win xp SP3.. but reasults are same.

    Also tried in Native database(fdb), but all effort went vain.


    Scenario :
    I have imported same(.txt) file through data port in different machine(without changing the local settings) , its showing irrelevant data in Nav database while comparing with txt file.

    While comparing with above mentioned data with other machine (with local settings) also not matching..
    i mean, In local setting(JAP) sys, file updated "株式" in the sense, without local setting (US) file got updated ".国.内" (while checking/opened same database in JAP system)
  • Options
    ara3nara3n Member Posts: 9,256
    contact local solution center in japan. It could be a different encoding on the file, but I don't know much about Japanese character set.
    What encoding is the file in. asci or ansi or unicode?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    supportnavsupportnav Member Posts: 34
    i forgot to mention, file type is TSV (Text file in a tab-separated values), Format is UTF-8.
  • Options
    ara3nara3n Member Posts: 9,256
    save the file as ascii instead of UTF-8 and then try and import it.
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    supportnavsupportnav Member Posts: 34
    ara3n wrote:
    save the file as ascii instead of UTF-8 and then try and import it.

    Thanks , now its working fine...

    any reason behind this ? as i know, UTF-8 is show correct figure compare to ASCII ? y this difference in DB, pls explain.. i mean ,y its not working with UTF-8.

    this same will for other languages also , i mean chinese, korean... bec we are doing accross country level...
  • Options
    ara3nara3n Member Posts: 9,256
    Current NAV version is not Unicode (UTF-8) compliant. Next version of NAV will be able to load Unicode fields.
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    supportnavsupportnav Member Posts: 34
    Thank you very much :)

    whether its possible to change file format from UTF-8 to ASCII through CAL coding ? or converting fields before importing ?
  • Options
    ara3nara3n Member Posts: 9,256
    i have never looked it up. i suggest to google it. the solution will involve some external dll or app
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    supportnavsupportnav Member Posts: 34
    ara3n wrote:
    save the file as ascii instead of UTF-8 and then try and import it.

    sry for the repeated question, actually i have used ANSI file , not ASCII file . it will make any difference ?

    Converted UTF-8 like, opened UTF file in notepad and Saved As ANSI.
  • Options
    ara3nara3n Member Posts: 9,256
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
Sign In or Register to comment.