Options

Choose profile dialog when sending email

stiastastiasta Member Posts: 106
Hello!
This is not really a problem, but more annoying.
I have created a CU that uses outlook automation server. When i finish composing the email and try to open the new message dialog, i get a dialog from outlook that says "Choose profile". Even if i have set the profile and made it a standard profile.
How can i make it so i do not get this dialog?

PS. This only happens when outlook is closed and i try to open a new dialog.

Comments

  • Options
    stiastastiasta Member Posts: 106
    i would like to bump this one. I am still struggling with this problem.
  • Options
    ta5ta5 Member Posts: 1,164
    Hi
    We had the same problem some time ago. It was NAS sending outlook emails. We then had to start oulook with the NAS service user and had the configuration for that profile. After that it worked. Imho its better to use smtp mails anyway, because you are not limited to outlook and you dont have problems with the profile.
    Hope this helps
    Thomas
  • Options
    stiastastiasta Member Posts: 106
    I have taken a screenshot of the dialog



    Nav is started from a webpage and uses Citrix, the same with outlook. (Incase that helps problemsolving)
    I have also tried to select this profile as standard, multiple times, but it doesnt help. The dialog still keeps popping up.
  • Options
    stiastastiasta Member Posts: 106
    I have not been able to find a solution yet. Wasn't as easy as i thought.
  • Options
    stiastastiasta Member Posts: 106
    Could it be that you have to specify profile when you run this automation (look in 397 cu and you will find oApplication)
    OApplication has a parameter in the method Logon that is called strProfile. Could this be the parameter that needs to be set?
  • Options
    mikmadmikmad Member Posts: 4
    Hello,
    did you find the solution?
    I have same problem.
  • Options
    BernardJBernardJ Member Posts: 57
    stiasta wrote:
    Could it be that you have to specify profile when you run this automation (look in 397 cu and you will find oApplication)
    OApplication has a parameter in the method Logon that is called strProfile. Could this be the parameter that needs to be set?
    That's the one
  • Options
    KarenhKarenh Member Posts: 209
    This is a problem where I work also. We all connect using remote desktop. Outlook is automatically opened in the remote desktop sesssion, and that used to solve the problem but not any more.

    Where can I get more information about the profile parameter for the Login method of Oapplication? Did that solve the problem?
  • Options
    KarenhKarenh Member Posts: 209
    I found a knowledge base article and hot fix for this. It applies to NAV 2009 R2

    Article 2729187 - Last Review: July 9, 2012 - Revision: 1.0
    The Choose Profile message box is opened in Outlook unexpectedly when you send email messages from Microsoft Dynamics NAV 2009
  • Options
    FDickschatFDickschat Member Posts: 380
    The KB article also says:
    - This problem occurs in Terminal Server and Citrix environments
    Nothing about WXP, Vista, W7.

    Did it work for you? I tried it too and here it did not work, neither on TS nor Citrix and definitely not on WXP nor W7. I tried this special build and also several newer ones.

    The solution can be found here:
    http://www.mibuso.com/forum/viewtopic.php?f=23&t=54864
    Frank Dickschat
    FD Consulting
Sign In or Register to comment.