Default NAV Server Instance

BeliasBelias Member Posts: 2,996
edited 2011-11-07 in NAV Three Tier
Hi everyone,
i've an easy (i think) question, but i don't know what keyword to search, so I ask you some minutes of patience :mrgreen:
When you start your nav rtc for the very first time, it automatically connects to "blablabla/DynamicsNAV/Service". What if that service does not exist/is down? Nav makes an error about " end point..." and then opens the select server window. Now you can digit the correct address and make the RTC work correctly every time you open it (the setting is saved somewhere).
Now, my customer will go-live with a lot of users, and he told me he don't want to receive that error, but wants the client to automatically connect to the correct database, which is, for example, on:

I just realized that in my development installations, i went straight with the select server window and insert manually the address...but how can i default my server name? some parameter for the executable, some setting...

hope it's clear, thanks in advance
"Never memorize what you can easily find in a book".....Or Mibuso
My Blog


  • MagfoMagfo Member Posts: 11
    Try editing the UserSetting file which is stored in your Program\...NAV\60\RTC-folder.

    In it you'll find the following:
    <?xml version="1.0" encoding="UTF-8"?>
      <add key="Server" value="SERVER" />
      <add key="ServerPort" value="7046" />
      <add key="Service" value="DynamicsNAV" />
      <add key="ProtectionLevel" value="EncryptAndSign" />
      <add key="UrlHistory" value="l" />
      <add key="CompressionThreshold" value="64" />
      <add key="ChunkSize" value="28" />
      <add key="AllowNtlm" value="true" />
      <add key="ServicePrincipalNameRequired" value="False" />
      <add key="OpenConnectionTimeout" value="00:00:30" />
      <add key="UnknownSpnHint" value="" />

    Try changing <add key="Service" value="DynamicsNAV" /> to your prefered service name.
  • BeliasBelias Member Posts: 2,996
    I was betting on that one, too, but i can't find it :?
    I can try to create it manually by copying from the installation DVD...
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
  • mdPartnerNLmdPartnerNL Member Posts: 802
    It's in C:\Users\???\AppData\Local\Microsoft\Microsoft Dynamics NAV
  • BeliasBelias Member Posts: 2,996
    yes, there it is! I completely forgot his location (i think i got in touch with it 2 times in total :) )
    thank you!
    actually, it was pretty absurd to have that file in the client installation folder :whistle:
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
  • Peter_Wibeck_[MSFT]Peter_Wibeck_[MSFT] Member, Microsoft Employee Posts: 78
    Remember that for every new user that start RTC the configuration file from C:\ProgramData\Microsoft\Microsoft Dynamics NAV is copied to C:\Users\???\AppData\Local\Microsoft\Microsoft Dynamics NAV

    So remember to update that file aslo if you expect new users to start the RTC client on the specific machine.
    “This posting is provided "AS IS" with no warranties, and confers no rights.”

    Peter Wibeck
    Software Development Engineer in Test
    Dynamics NAV Server and Installer team
  • einsTeIn.NETeinsTeIn.NET Member Posts: 1,050
    I think in newer versions the location of the file changed from subfolder Local to subfolder Roaming. However, I still have an issue here. If I try to run an object by HYPERLINK and GETURL, it still starts RTC in another session instead of the current one, and it tries to connect to a complete different server. Not the one that it's currently connected to, and not the one that is mentioned in the config file in my user folder. Any idea where this might be coming from?
    "Money is likewise the greatest chance and the greatest scourge of mankind."
  • vaprogvaprog Member Posts: 1,093
    Where is the error? Does GETURL return an incorrect hyperlink or does the correct url not open the correct client/company?

    In the former case it should be expected that you don't get where you expect. Check the parameters for the function.

    In the latter case I would check DNS and name resolution in general (hosts file, WINS, DNS cache ...) and also try a repair installation, first of the client, and, if that still did not help, of the middle tier server also.
  • einsTeIn.NETeinsTeIn.NET Member Posts: 1,050
    edited 2023-05-19
    Correct, GETURL already returns the wrong URL. There's nothing I could check with regards to the parameters. It's set to current client type, nothing else. Again, it returns a URL that is neither composed of the server the session is currently connected to, nor composed of the server that is set in the config file. It seems to be a server that was used way in the past, and that doesn't exist anymore. I also already checked registry, but there's no entry like this.
    "Money is likewise the greatest chance and the greatest scourge of mankind."
  • vaprogvaprog Member Posts: 1,093
    Please check the Server Instance (Id 2000000112) and Active Session (Id 2000000110) tables for stale entries and delete them.
  • einsTeIn.NETeinsTeIn.NET Member Posts: 1,050
    edited 2023-05-19
    Active Session does not contain any suspicious entry. In fact, just mine where all the session values are correct.

    I can't run Server Instance as it says, you can't run it because the table contains system data. If I run it in SSMS, it just contains one record with the correct values of the current instance.
    "Money is likewise the greatest chance and the greatest scourge of mankind."
  • vaprogvaprog Member Posts: 1,093
    Is at least one of the involved services created as an instance (Add Instance from the administration management console snap-in or equivalent)? Does it work for the originally installed service?
  • einsTeIn.NETeinsTeIn.NET Member Posts: 1,050
    All services have been created either by Administration Snap-in or by PS. However, the server that it points to, has been deinstalled in the meantime. Like I said, it's an old service that was used in the past, and somehow it still refers to it.

    Yes, it works in other circumstances. E.g. if I run the object from within Dev environment, it opens the selected instance correctly. Also, if I run an object from an instance of another server, it doesn't try to switch the services.
    "Money is likewise the greatest chance and the greatest scourge of mankind."
Sign In or Register to comment.