Nav Web Services does not working

NewNavNewNav Member Posts: 4
edited 2011-11-01 in NAV Three Tier
Hi everyone,

I have a big problem, i have a Nav R2 on Window 2008 r2 Enterprise. I try to do an application for to use the web service of Navision but when i call for these web services I have some problem like this:

*HTTP 500 Internal Server Error

I saw the two winwdow service and both are running. When i go to the event viewer, i can see this error

<detail><string xmlns="">The user ID and password are invalid. Try again.</string></detail>

But is error is very strange because i connected with the administrator.

Pleaseee HELP!!!!!


  • JAJJAJ Member Posts: 52

    Do you have the windows user Administrator like NAV user?
    In order to work with NAV Web Service you must have the user (In your case Administrator) like a NAV user.

  • mikmik Member Posts: 79
    Error 500 will not help you to solve the problem.

    Try this
    1) Click Start, click Settings, click Control Panel, and then double-click Internet Options.
    2) Click the Advanced tab.
    3) Click the Show friendly HTTP error messages check box to clear it.
    4) Click OK.

    With kind regards
  • NewNavNewNav Member Posts: 4
    Yes, my user is a "super" user in Nav.
  • NewNavNewNav Member Posts: 4

    I have a new message of error.. let me show you.
  • mikmik Member Posts: 79

    have a look in you service config file. (Customsettings.config)

    Set WebServicesUseNTLMAuthentication to false if it is true.
    <add key="WebServicesUseNTLMAuthentication" value="false"></add>

    You will be asked for a username and password. Try with a user which has the role SUPER.

    With kind regards
  • kinekine Member Posts: 12,562
    When solving Error 500, do not forget to describe the infrastrucutre: is the WS serverrunning on same server as SQL? If not, have you set correct SPNs and enabled the delegation for the WS Server?
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • DuikmeesterDuikmeester Member Posts: 304
    Two things you could try is use the computer-name instead of localhost, and make sure that intranet pages are trusted so Internet Explorer allows sending user credentials to the service.
Sign In or Register to comment.