Options

Report.runmodal

nazunazu Member Posts: 70
Hi,
I have a preoblem with the report.

My report is not processing only.

When i do preview records are getting inserted in a table.I have written report.run(001,false,false,rec);
I am passing False as a parameter to the report so that it will take the prinetrer id from teh Printer selection table(I have kept my prienter selection table empty for this report as i dnt want to print it)but still it is gng to the default printer set on my compauter.

The false parameter is not workin.Any ideas why?

Comments

  • Options
    ufukufuk Member Posts: 514
    nazu wrote:
    Hi,
    I am passing False as a parameter to the report so that it will take the prinetrer id from teh Printer selection table(I have kept my prienter selection table empty for this report as i dnt want to print it)but still it is gng to the default printer set on my compauter.

    The false parameter is not workin.Any ideas why?

    Do you want to use the printer in printer selection table or not? You said you want to take printer id from this table but then said you kept this table empty for not using the printer.
    Ufuk Asci
    Pargesoft
  • Options
    nazunazu Member Posts: 70
    Thans for the reply.Basically i dont want to print the report.Even preview can also be done as my main intention is to populate the data in the table by running the report.
  • Options
    mohana_cse06mohana_cse06 Member Posts: 5,504
    nazu wrote:
    My report is not processing only.

    Is there any particular reason for this?
    Did you try by setting processing only?
  • Options
    PeterVersteegePeterVersteege Member Posts: 13
    Setting this parameter to False means that Navision searches in the Printer Selection table which printer it should use. If the Printer Selection-table is empty, Navision automatically uses the default printer which is defined on this computer. So having an empty Printer Selection table doesnot mean that the report will not be printed.
    K3 Business Solutions
Sign In or Register to comment.