Options

Problem with PDF Creator while processing through NAS

sunctsunct Member Posts: 72
Hi,

I am facing a problem with the PDF Creator when executing through NAS. I have a report which will create PDF Documents and send through email. In our development environment this works fine if I run the report from NAV client and as a job queue entry through NAS. It is not giving errors. But when we tried this report in production environment it is logging error to Job Queue Log Entries while executing through NAS. From the nav client it works fine.

This message is for C/AL programmers:

Could not create an instance of the OLE control or Automation server identified by
GUID={1CE9DC08-9FBC-45C6-8A7C-4FE1E208A613} 4.1:{3A619AE4-50EC-46C8-B19E-BE8F50DD2F22}:'PDFCreator'.clsPDFCreator.
Check that the OLE

We are using the same version of PDF Creator in both environments. NAS build is also same. It is quite confusing why this happens in one environment not in the other.

I have seen some related posts here, but I didnt get a proper solution from those. Please help.

Thanks in advance,
Regards,
Sunil

Comments

  • Options
    AKPJAKPJ Member Posts: 4
    Hi

    Copy the file PDFCreator.exe from 'C:\Program Files\PDFCreator\PDFCreator.exe' to your NAS folder.

    It will work :D

    Regards
    AKPJ

    "God save the King"
    "Be Vegetarian"
  • Options
    ara3nara3n Member Posts: 9,256
    The error is that your client has a different pdf creator than the one you are using. make sure you running the same version.
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
Sign In or Register to comment.