Options

'Could not load selected type library' & Date in Data Migrat

AtreiuAtreiu Member Posts: 51
Hi everybody,

I'm getting crazy with this:

I wanted to use the page NAV Data Migration to import data (NAV 6.0). The sequence was: write data in sql table (with a query) Migration Record and Migration Data. Then I try to apply them and the records are imported correctly, but the Date fields are blank.


Reading on the internet it seems to be a problem in Automation objects. I don't know much about them, but I found that really some Automation variables are missing in CodeUnit 8611: XlBook, XlApp, XlBook. Beside them is written: "Unknown Automation Server.Unknown Class"

The other problem is that I cannot compile this Code Unit nor save it. But the main issue is that I don't know how to fix this problem.

If the solution is in finding these files and re-register them, I cannot find these files anywhere in my pc or my collegues'... I don't even know if the problem is in this Code Unit... We have tried an import in NAV 5.0 and the Code Unit has the same problem of Automation, but import behave correctly with dates...


I know I did not make myself so clear...

but thanks!

Comments

  • Options
    DigiTecKidDigiTecKid Member Posts: 46
    Those are Excel automations, do you have Excel installed on this computer? If not I don't think there is a way of getting and using just those automations without installing Excel. (although i have never tried that before)
    If you do have Excel installed it doesn't like your version. (although i can't ever remember having that problem with MSOffice automations, [installing new versions breaking access to old version automations])

    And yes, without access to those automations you will not be able to save those objects compiled...
Sign In or Register to comment.