Missing "Automation" datatype

matthijsm81matthijsm81 Member Posts: 6
I'm trying to work through the "Walkthrough: Using Automation to Write a Letter in Microsoft Office Word." When trying to write the codeunit I don't have the Data Type "Automation". I've tried to find for a solution online, but I don't seem to find one...

...would anyone be able to help me on this?


  • Options
    ta5ta5 Member Posts: 1,164
    Is word installed on that workstation?
  • Options
    matthijsm81matthijsm81 Member Posts: 6
    Yes, it is - Office 2010 is installed. I'm running a local C/Side database with a 2009 client.
  • Options
    matthijsm81matthijsm81 Member Posts: 6
    How stupid of me, I was using the wrong license in the NAV folder, it's missing granule 1750 (for some reason).
  • Options
    SonGoten13SonGoten13 Member Posts: 44
    Hey there,

    I got a similar problem with the Automation datatype not available anymore.
    We have a client with a development licence but without granule 1750 C/OCX. So we used to change(LicenseInfo->Change) the licence to our own partner licence with the granule if we had to do stuff with automation.
    But since a while this doesnt work anymore. Recently i found out that if i UPLOAD the licence with granule 1750 and restart the client i have again access to the automation datatype.
    We did several upgrades to navision and the sql-server, so i don`t know anymore if it stopped working after a specific update or when, as we don´t use it so much.
    I tried with different builds: NAV 6.0SP1(6.00.31085) with SQL2008 10.0.1600.22 SP1 Developer Edition(64bit); NAV 5.0SP1(6.00.31085) with SQL2008 10.0.1600.22 RTM Developer Edition; NAV 6.0R2(6.00.32012) with SQL2008R2 9.00.4053.00 SP3 Express Edition; NAV 5.0(5.00) with NAV-Database.
    It worked in none of them, means i always have to UPLOAD the licenze, changing is not enough.
    But i am sure it worked once. Maybe it has to do with a change in the Microsoft Licence Model (don´t know much about that) ?
    Anyone got information about that?

  • Options
    bbrownbbrown Member Posts: 3,268
    I've run into this situation recently. I tend to work remotely quite often and will connected via Terminal Service and do a license change back to my DEV license on my local computer. On this one site it's not uncommn for me to be connected over a long period of time. What I found was that the connection back to my local drives seems to get corrupted (for lack of a better term). It still appears but doesn't properly read the license file. After logging out and reestabishing a fresh connection, the OCX (automation) would show up. Not sure of the underlying cause but think it may just be a loss on connectivity that occurred while session was connected.

    Doing a license upload with a DEV license to a customer system is a very bad practice.
    There are no bugs - only undocumented features.
  • Options
    SonGoten13SonGoten13 Member Posts: 44
    I am working the same way you described, but it cannot be a bad connection, because i have the same problem if i try it local(upload the customer licence to my local NAV then change it to my DEV licence).
    bbrown wrote:
    Doing a license upload with a DEV license to a customer system is a very bad practice.
    Yeah i know, and we are not doing that (just tried it once, but changed it right back), that's why i am trying to find a solution on this.
  • Options
    FommoFommo Member Posts: 138
    Any more suggestions around this???
    I have this exact situation now. It's a customer with a NAV 4.0 SP3 database running on 5.0 SP1 clients.
    When I run my code in my local NAV 4.0 W1 it have no problem with automation, but when I try to import to customer with the same license (our developer license) I'm not allowed. In this particular case they wont be using the automation parts of the code, but I don't wanna remove all the references. ](*,)

    Any ideas what to do? I can't upload our developer license as it's a production server and they have other addons in their license.
Sign In or Register to comment.