[Part-Resolved] RTC - Division Error - Not in Native

David_CoxDavid_Cox Member Posts: 509
edited 2010-11-18 in NAV Three Tier
Hi Guys,
I have taken the standard Invoice report added a "page loop footer", populated the footer fields (=Code.GetData(11,3)) and they show just what I wanted in Print Preview.

However the print preview is just the one list, when I choose to output to the printer an invoice of more than one page I get an RTC [Division Error] message, this is not a problem with native as I do not get the message.

So it is specific to the RTC, any advice welcomed.

David ](*,)
Analyst Developer with over 17 years Navision, Contract Status - Busy
Mobile: +44(0)7854 842801
Email: [email protected]
Twitter: https://twitter.com/Adeptris
Website: http://www.adeptris.com

Comments

  • BeliasBelias Member Posts: 2,998
    is "Division Error" the text of the message?
    if so, can it be a division by zero done in the report custom code?
    -Mirko-
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
  • David_CoxDavid_Cox Member Posts: 509
    Hi Belias,
    It is the RTC Reporting 'Error Message',
    I can run the report in the classic backend, and all pages for all Sales Invoices no error, that is over 1000 pages.
    I can print preview the report in RTC no problem.

    Press send to printer, any printe,r and as it prints the pages the error happens, nothing is sent to the printer.
    So it looks like something to do with the pages, maybe 'total pages / page number' or something else hidden in the RTC report.

    Changes I have done is to add a Page Loop Footer to the Report sections with some new fields, named the fields and added them to a set variable in the RTC Layout, added a report footer in the RTC Layout and added the fields.

    All works except 'Send to Printer' so I am thinking it's an RTC report issue rather than a native code issue.

    David
    Analyst Developer with over 17 years Navision, Contract Status - Busy
    Mobile: +44(0)7854 842801
    Email: [email protected]
    Twitter: https://twitter.com/Adeptris
    Website: http://www.adeptris.com
  • BeliasBelias Member Posts: 2,998
    yeah, i think so, too...did you already try to save as excel/pdf?is the problem still there?if not, it seems to be printer related only, which is very strange...
    otherwise i would proceed by deleting controls, starting from the most suspicious...after you identify what is the bad control, you can start to figure out what is the problem. So far, this is my personal experience about "debugging" reporting services...
    -Mirko-
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
  • David_CoxDavid_Cox Member Posts: 509
    Hi Belias,
    Thanks for your reply,

    The problem was to do with a footer background image.

    When I removed the image the report worked, I have to embed the images in the report the header and body are fine, So I need to trim the footer image a little to stop the error.

    All the report margin's are set to '0' to allow for the images, and the page set to size, I will need to trim it slightly, the pre-printed image was the reason for needing the VAT analysis in boxes in the report footer.

    half a days work in classic (without background images), and a nightmare in RTC!

    Not sure if there is an easier way to overlay the report on an image in RTC?


    David
    Analyst Developer with over 17 years Navision, Contract Status - Busy
    Mobile: +44(0)7854 842801
    Email: [email protected]
    Twitter: https://twitter.com/Adeptris
    Website: http://www.adeptris.com
  • BeliasBelias Member Posts: 2,998
    Hi David,
    I'm not sure i've understood your last post...can you explain it better (when you have time), maybe with a screenshot, please?(if possible)
    i'm curious about the error cause.
    thanks!
    -Mirko-
    "Never memorize what you can easily find in a book".....Or Mibuso
    My Blog
Sign In or Register to comment.