Options

Error when renaming record (G/L Account)

kaspinkaspin Member Posts: 14
Hi all!

I have weird problem when trying to rename G/L Account."No." -field. When answering Yes to question "Do you want to rename the record" I get error "Field no. 296704 is not defined in the G/L Account table." G/L Account table is not modified. Doing this in native database with same backup works fine. When I tried this with year old backup in SQL database it works fine.

When trying to debug, I get nothing, error comes before debugger activates?

I have Navision 4.03 and SQL 2005. Also Navision 4.01 and SQL 2000 gives same error.

Any Ideas? :D

Answers

  • Options
    mrsamrsa Member Posts: 35
    Maybe is related change log, try to make rename wihtout change log, if it is logging included.
  • Options
    diptish.naskardiptish.naskar Member Posts: 360
    Hi,

    First try to compile the G/L Acc. table which is present with the SQL Server.
    Diptish Naskar
    For any queries you can also visit my blog site: http://msnavarena.blogspot.com/
  • Options
    matttraxmatttrax Member Posts: 2,309
    And there's always exporting all objects to text and searching for that field number.
  • Options
    kaspinkaspin Member Posts: 14
    Thank you all for ideas.

    I have tried all of them, I did not find anything from text export, re-compiled G/L account table and checked change log (which is not activated)...

    What happens before debugger kicks in when trying to rename records?
  • Options
    FDickschatFDickschat Member Posts: 380
    I more or less had the same issue a while ago.

    While programming data transfer from an old 2.60 FR into a 6.01 DE we spared some time by exporting the old 2.60 GL Account table object into text, changing the number and importing the object into the 6.01 and a staging table. There we deleted all code, functions and variables from the table but did not check on table relations. But there were some existing which pointed from that import table to a non existing field / table.

    Export all objects to text did not help as you will not be able to find the field number in the text. When we identified what the problem was we scanned in all 20 import tables we had done like this all fields and easily found the wrong table relations.
    Frank Dickschat
    FD Consulting
  • Options
    FDickschatFDickschat Member Posts: 380
    I was just checking on something else and stumbled over this:
    Create a new tabular form for table 2000000041 (Field), put in all fields and run it. The form will display 2 columns RelationTableNo, RelationFieldNo. No idea whether it helps but it's worth a try.
    Frank Dickschat
    FD Consulting
  • Options
    rmv_RUrmv_RU Member Posts: 119
    Try to compile all tables. I think you have some objects from another project.
    Looking for part-time work.
    Nav, T-SQL.
  • Options
    kaspinkaspin Member Posts: 14
    Now I tried to recompile table objects and got 2 errors. Table 6206 (E-Mail Queue) and table 6215 (Picture). These error concerned about (MAPIHandler variable for T6206 and Image variable for T6215) automation objects. G/L Account table has Picture field, but I did not see any connection with T6215.

    I also made the form for table Field. This is good tip, but I did not find problems with table relations with it.

    ](*,)
  • Options
    rmv_RUrmv_RU Member Posts: 119
    Check triggers:
    1. "G/L Account".OnRename
    2. ApplicationManagement.OnGlobalRename
    Looking for part-time work.
    Nav, T-SQL.
  • Options
    kaspinkaspin Member Posts: 14
    OnRename there is only "Last Date Modified" and OnGlobalRename ChangLogMgt.LogRename(RecRef,xRecRef), but this is not activated, logging is not.
    Update: this seems to happen also with other installations with 4.01 and SQL 2005!
  • Options
    kaspinkaspin Member Posts: 14
    I found the error. It was incorrect table relation in other table to G/L Account table. I exported all the tables to test, as mattrax suggested. For some reason I dd not find it in the first time...Typing error maybe :oops:

    Thank you all!
Sign In or Register to comment.