Options

sp_rename error when importing translated captions

lvanvugtlvanvugt Member Posts: 774
I have been translating our application (based on the translate export) and when ready wanted to import (using translate>import) it into our application objects again. For the majority of the objects this worked OK, but for a small subset (~20 objects) I am getting the following error:
---------------------------
The following SQL Server error or errors occurred when accessing the Company Information table:

297,"42000",[Microsoft][ODBC SQL Server Driver][SQL Server]The user does not have permission to perform this action.

SQL:
{CALL [sp_rename](?, ?, ?)}
---------------------------
where of course the table mentioned will vary.
Searching for posts on sp_rename brought me to this one:
BUG Renaming fields fails at SQL “named instances”
It doesn't however help (whilst it's claiming that a similar issue should have been fixed in later NAV builds). Here on mibuso I did not succeed in finding any posts.
Anybody a clue on how to solve this?
One funny phenomenon was that with some objects this error occured the first time I tried to import, but when retrying (2nd, 3rd, ... time) it worked.

The system I am running on is:
    Windows Server 2003 R2 SP2 NAV 2009 SP1
(haven't got more details on it at hand)
Luc van Vugt, fluxxus.nl
Never stop learning
Van Vugt's dynamiXs
Dutch Dynamics Community

Answers

Sign In or Register to comment.