Troubles Installing Navision 4.0 multiple Database Services

mvlietmvliet Member Posts: 22
Hello all !!

I'm having trouble installing multiple navision 4.0 database services on one server !

Installing a single database service on a server is no problem, but installing multiple is (in my case).

Here is what i did:

- Installed the new Database software [Installatie 4.0 NL]
- Copyed the entier [Database Server] directory to [Database Server ExSION] directory
- added a entry in the services file [EXSION40 - 15008]
- added a entry in the hosts file [EXSION40 -]
- ran my serverinstall.bat
"C:\PROGRA~1\Microsoft Business Solutions-Navision\Database Server ExSION\server.exe" servername=EXSION40, NETTYPE=TCPS, CACHE=60000, DATABASE="F:\NAVDATA\Data\HBSadmin\Exsion\Exsion reporting40.FDB", INSTALLASSERVICE

so far no problems what so ever

now connecting with a client to the service:

- added a entry in the services file [EXSION40 - 15008]
- added a entry in the hosts file [EXSION40 -]
- ran the 4.0 client
- changed connection type to TCPS
- connected to EXSION40

Than i get one of the following errors:
1. error about packet los to the server (wich is BS cause we don't have those problems with other services)
2. standard TCP error (CONNECTION REFUSED) e.a. like if the serices or hosts file is filled incorrectly
3. the client locks up if you try connecting with TCPS to a TCP service (you need to kill the client in order to shut it down)

I've tried changing to the "reagular" TCP connection instead of the kerebos TCPS connection (what's up with that anyway ? i can't find anything about TCPS in the documention yet !!)

anyone got multiple 4.0 database services running ?
or does someone have hints/tips/suggesions on where to go next ?




  • Options
    mvlietmvliet Member Posts: 22
    ok small update:

    the "old" TCP connection is working now, but TCPS (kerberos encryption) still doesn't :roll:

    any hints on that ?
  • Options
    mplatvoetmplatvoet Member Posts: 34

    I tried the same thing with one server and TCPS, and teh same thing: it doesn't work....

    Strange thing that MBS publishes this feature and has no documentation about it at all!javascript:emoticon(':evil:')
    Evil or Very Mad

    For now I work with standard TCPIP...
  • Options
    Marco_HeurterMarco_Heurter Member Posts: 1
    Afther some hours i managed to install a mulitpul database server.
    it was at some piont abit tricky but here is how i did it.

    install the 4.0 server (named live)
    copy the data to another directory (named test)
    **note that u have to choise for the nettype tcp cause tcps doesn't work.
    or it may work but haven't figured it out yet.

    then change the settings of the live inferment and install and start the service.
    then change the setting of the test informent and install and start the service.
    **note if u view the settings during the change u may note that it doesn't matter witch server u look at the setting are both the same i think it still a little bug perhapse, cause in the old days if u where in the live server folder u would see the live server settings and vica versa for the test informent.
    but now with 4.0 it doesnt matter in witch folder im in , i always get the same settings. anyway
    afther u have installed both servers change the services and host files,
    and then start the server.

    if u try to open a server through a client u may notice that it still say's it can't find any server, this is because the client by default tries to logon with the tcps protocol u can change this in the database connection screen under the advange tabbloid.

    **sometimes i like to work with a desktop icon to connect directly to a server, also here in the old days i only had to use the parameter "servername=" and i was in. now u also have to say "nettype=tcp" or it will try to connect with the tcps protocol again.

    hope it works out...
    gr marco

    (or let me know if it doesn't then perhapse i can help u with it)
Sign In or Register to comment.