RTC can't connect to server

dbabasdbabas Member Posts: 33
edited 2010-06-02 in NAV Three Tier
Hello all.
I'm trying to install nav 2009 SP1 in 2 machines. A server (named navsrv) and a client. I have followed step by step the walkthrough I found within the installation DVD and all installation steps finished without any errors.
When I launch RTC, I receive the following message:

A server was not found at "net.[url=tcp://navsrv:7046/nav2009/service]tcp://navsrv:7046/nav2009/service[/url]". Either the URL is incorrect or the server is currently not available.

I would also like to mention that:

1.When I'm using classic client I'm connecting to the server without problem
2.The server OS is windows 2003 and the SQL version is 2005.
3.The instance of SQL server (named nav2009) is not the default.
4.The client OS is windows 7.
5.I have already disable firewall on both the server and the client.
6.The user of the client PC is an administrator user on SQL Server.
7.I have already start SQL browser and I can connect via SSMS.
8.I have already enable named pipes for the nav2009 instance.

Any idea, please?

Thanks in advance.


  • Options
    pablosnpablosn Member Posts: 5
    I also some problems with installation, and i found this tool really useful:


    It checks for common problems in the setup.
  • Options
    dbabasdbabas Member Posts: 33
    Thank you for your response pablosn.
    Unfortunately, I have just tried the tool you suggested and it doesn't identify any problem.
  • Options
    Peter_Wibeck_[MSFT]Peter_Wibeck_[MSFT] Member, Microsoft Employee Posts: 78
    Have you tried to run RTC from the same machine (navsrv) as the server is installed on to verify that the server is working correctly?
    “This posting is provided "AS IS" with no warranties, and confers no rights.”

    Peter Wibeck
    Software Development Engineer in Test
    Dynamics NAV Server and Installer team
  • Options
    EgnazEgnaz Member Posts: 111
    Have you installed the ServiceTier ?
Sign In or Register to comment.