Options

NonStock Items

hpdnavhpdnav Member Posts: 5
I would like to use the Import Nonstock Items dataport #5700 in NAV.

I have created a comma-delimited file but when I use the dataport, it only creates one entry. I have also tried to import another comma-delimited file but it overwrites the previously created file.

I do not want to create new Items.

It seems as though the dataport is unable to create a new record.

Does the Import Nonstock Items dataport need to be modified so that I can use it as I would like?
If not, how can I get it to create more than one entry?

Thank you

Comments

  • Options
    themavethemave Member Posts: 1,058
    it has something to do with your file, I use the dataport to bring over a hundred thousand non stock items. sorry can't be more helpful.

    the dataport has the start and end delimters as " (qoute) and the separator as a coma
  • Options
    hpdnavhpdnav Member Posts: 5
    here are two lines in the comma-delimited file I am using:

    "OP - SVC","15046","12345ART567","TEST PART ONLY","EA","200","10","90","20","22"
    "OP - SVC","15046","14400PC6004","belt, timing,jpn,ka","EA","100","50","45","10","11"

    I have based it with another file that I use for import but I can't get this one to work.

    Am I missing something?

    Thank you for help in advance.
  • Options
    themavethemave Member Posts: 1,058
    hpdnav wrote:
    here are two lines in the comma-delimited file I am using:

    "OP - SVC","15046","12345ART567","TEST PART ONLY","EA","200","10","90","20","22"
    "OP - SVC","15046","14400PC6004","belt, timing,jpn,ka","EA","100","50","45","10","11"

    I have based it with another file that I use for import but I can't get this one to work.

    Am I missing something?

    Thank you for help in advance.
    If you are using the standard dataport
    the fields are:

    Enabled SourceExpr StartPos Width
    Yes "Manufacturer Code" 0 0
    Yes "Vendor No." 0 0
    Yes "Vendor Item No." 0 0
    Yes Description 0 0
    Yes "Unit of Measure" 0 0
    Yes "Published Cost" 0 0
    Yes "Negotiated Cost" 0 0
    Yes "Unit Price" 0 0
    Yes "Gross Weight" 0 0
    Yes "Net Weight" 0 0
    Yes "Bar Code" 0 0

    your file might have a problem with the comms in the description of the second line
  • Options
    hpdnavhpdnav Member Posts: 5
    I have removed the comma's from the description in the 2nd line but it still only pulls in the 2nd line.

    Do I need to insert some code into the dataport?

    If so, is that what you provided as an example?
  • Options
    hpdnavhpdnav Member Posts: 5
    Hello,

    Ok, I see what you mean. Yes, all those fields are enabled in the design view of the table.

    I have tried setting it up with both Entry No. and Vendor Item No. None add more than one entry.

    If possible, could you please provide one or two lines from your import file?

    Thank you
Sign In or Register to comment.