Options

NAV501 menusuite item keeps jumping to original location

CentauroCentauro Member Posts: 3
Hi everyone,

We have encountered a problem when we were trying to move a menusuite item in the navigation pane designer.
The menusuite item links to a form that is positioned into the 50xxx series, custom development.
When we compile the changed navigation pane, we have noticed that the menusuite item always jumps back to its original location.

We have tried several things but none of them worked for us:

[*]Used the CTRL-SHIFT-DOWN/UP keys
[*]Used the Copy and Paste method (Cut - Paste also tried)
[*]Tried removing the ZUP

The form which the menusuite item refers to has been recompiled and readded to the menusuite, didn't help either.
The Menusuite range is 90.

If anyone could please help us out, we would be very happy ^^.

Thanking you in advance,

Centauro

Comments

  • Options
    matttraxmatttrax Member Posts: 2,309
    Well, Menusuites are stored as the difference between a higher level menusuite. So just because you modify one doesn't necessarily mean you are really changing it. Try to look at the others as well.

    Incidentally I have a similar problem. I have disabled a menu in every menusuite I have, yet it still appears on the list.
  • Options
    CentauroCentauro Member Posts: 3
    We have checked everything that we could check that relates to the levels of the menusuites, and we have found nothing out of the ordinary.

    I am hoping another solution/workaround can come out of this wonderful forum, we are riddled by this issue.

    Thanking you all in advance,

    Centauro
  • Options
    rdebathrdebath Member Posts: 383
    Export all the Menusuites to text.
    Search and destroy.
    Note that the GUIDs in the file are what links items in different menusuites and delete more.
    Import the ones you changed.
    If you changed 10 or 30 you have to delete the object in the database first.

    Beware: Depending on your version it is possible to crash Navision by confusing it with menusuites. You'll probably have to delete your ZUP file to get into the DB if it happens.
Sign In or Register to comment.