Options

NAS Error: MMC could not create the snap-in

Ms10KeyMs10Key Member Posts: 13
We had installed the NAS for use with Outlook Integration for NAV 2009. We then upgraded the executible to NAV 2009 SP1 and had to reinstall the NAS. It had been working fine with 2009; however, now, with SP1, we are receiving the following error:

MMC could not create the snap-in. The snap-in might not have been installed correctly. Name:Application Server for Microsoft Dynamics NAV Manager CLSID: {50000003-0000-1000-0001-0000836BD2D2}

I have reviewed similar posts on MIBUSO and have installed Microsoft Visual C++2005 Redistributable Package. We re-booted the server and still are experiencing this error. We cannot start/stop the NAS Service because it has not been configured and we cannot configure it without the snap-in.

All help is greatly appreciated!

Comments

  • Options
    krikikriki Member, Moderator Posts: 9,098
    Problems with the NAS-snapin in older versions made me write this how to : http://www.mibuso.com/howtoinfo.asp?FileID=15.

    You can try with the how-to.
    Regards,Alain Krikilion
    No PM,please use the forum. || May the <SOLVED>-attribute be in your title!


  • Options
    aniruddha_majumdaraniruddha_majumdar Member Posts: 57
    Hi Alain,

    In my all previous installation of NAS, I always used the command (nassql appservername=NASSERVER ....)to install NAS. But, in my current installation in one of my clients' environment, the system is throwing error as "The operating system cannot access to the file NASSERVER"


    In another method where I have installed the Classic Application server using executable, the NASSnapin is giving error as "MMC could not create the snap-in. The snap-in might not have been installed correctly. Name:Application Server for Microsoft Dynamics NAV Manager CLSID: {50000003-0000-1000-0001-0000836BD2D2}"


    Please can you please help in resolving the issue.
    Thanks & Regards,
    Aniruddha
  • Options
    geronimogeronimo Member Posts: 90
    i had the same problem before. Installing it through the normal setup instead of the msi solved it for me.
  • Options
    aniruddha_majumdaraniruddha_majumdar Member Posts: 57
    Hi All,

    Though Snapin problem still exists but the installation via command happened as it was due to some permission error.

    Thanks & Regards,
    Ani
    Thanks & Regards,
    Aniruddha
Sign In or Register to comment.