role tailerod client can't be connected to demodb

hewajithhewajith Posts: 96Member
edited 2009-08-31 in NAV Three Tier
My installation is three machine installation.
Afrte creating SPN I tried to connect to demo DB the following massage appears.

"'The Microsoft dynamics NAV server can not connect the Change Listener to SQL Server due to the following error: Cannot open database ‘’Demo Database NAV (6-0) requested by the login.
The login failed
Login failed user ‘ENABLINGQLD\PANTHOM$’’

Has anyone had this sort of error massage????/

Comments

  • kinekine Posts: 12,562Member
    Have you added this user into the NAV through classic client? Have you set permissions for this user? Installation added the user who installed the NAV as SUPER user into the database. Other users must be added manually...
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • hewajithhewajith Posts: 96Member
    This is the user who installed the NAV db server and App srever.
    Any how I manage to set up some of the parameter given in Walkthrough: Installing the Three Tiers on Three Computers document and now I ended up with this error massage

    ''The login failed when connecting to the SQL server DB6"'

    where DB6 is the SQL server Name.

    I did not perform LAST part of the Walkthrough: Installing the Three Tiers on Three Computers document. that is

    To delegate access to the SQL Server service>>> http://msdn.microsoft.com/en-us/library/dd301254.aspx

    step 9.>>>> I can't see MSSQLsvr service is running when I click users or computers
    what will be the possible reasons for that



    Thanx
  • kinekine Posts: 12,562Member
    Ok, you need to finish the last step. Why you do not see it - may be because you are looking on wrong PC? :-k
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • hewajithhewajith Posts: 96Member
    NO.. that is active directory server .but it is not listing srevices when i click on users ansd computers step 8 and then I can't see MSSQLSvc,.....

    To delegate access to the SQL Server service
    1. Click Start, and then click Run.

    2. In the Open field, type dsa.msc.

    This opens the Active Directory Users and Computers utility.

    3.Right-click the node for the domain where you have installed Microsoft Dynamics NAV, and then click Find.

    4. In the Find Users, Contacts, and Group dialog box, type the name of the domain user in the Name field, and then press ENTER.

    5. In the Search results area, right-click the domain user, and then click Properties.

    6. On the Delegation tab, click Trust this user for delegation to specified services only, and then click Use Kerberos only.

    There is also the option to not restrict authorization to Kerberos, though the environment is not as secure when you are less restrictive. Your decision on this point must be reflect in the value you assign to the AllowNtlm setting in the RoleTailored client configuration file (ClientUserSettings.config). See Configuring the RoleTailored Client for details.

    7. Click Add to open the Add Services dialog box.

    8. Click Users or Computers, and then specify the domain user.

    9. In the list of services for the domain user, click MSSQLSvc, which is the SQL Server service.


    Thnkx

    10. Click OK to close the Add Services dialog box. Continue clicking OK to close all open dialog boxes
  • krikikriki Posts: 8,764Member, Moderator
    [Topic moved from 'NAV/Navision' forum to 'NAV 2009' forum]
    Regards,Alain Krikilion
    Use the SEARCH,Luke! || No PM,please use the forum. || May the <SOLVED>-attribute be in your title!
    NAV TechDays 2019: 21 & 22 November 2019, Antwerp (Belgium)
Sign In or Register to comment.