3-tier Installation - Windows Server 2008

Scott_FrappierScott_Frappier Member Posts: 90
edited 2009-08-12 in NAV Three Tier
Hello everyone - I've been running into some issues with an installation at a client site and I've been scratching my head. I gone through installations of a 3-tier environment in many other installations, but for some reason that I cannot identify, I cannot identify the differences.

Basically, we're trying to do a 3-tier installation on separate machines on a Windows 2008 domain with the functional level set to Windows Server 2003. I have tried this multiple times and it is in a virtualized environment.

Basically, when trying to connect with the RTC to the NST, there is a timeout that occurs and an error message stating that the server does not exist. This only occurs from an external client and not from the RTC when located on the NST server (connecting locally). The setup is as follows (and yes I have gone through the walkthrough multiple times - I have a support incident open with Microsoft as well):

All 64-bit (except for Client Tier)
Windows Firewall Disabled on all Servers and Workstations (to rule out TCP issues)
AVRVMADC01 - Windows Server 2008 Active Directory
AVRVMSQL01 - Windows Server 2008 Member Server - SQL Server 2008
AVRVMNAV01 - Windows Server 2008 - NAV Service Tier
AVRVMCLIENT01 - Windows XP SP3 - RoleTailored Client

Specifics on setup - AVRVMADC01:
Active Directory Domain Controller
* Domain Functional Level = Windows Server 2003
* Forest Functional Level = Windows Server 2003
MSSQLService (Domain User)
* setspn -A MSSQLSvc/AVRVMSQL01:1433 AVR\MSSQLService
* setspn -A MSSQLSvc/AVRVMSQL01.avr.dom:1433 AVR\MSSQLService
DynamicsNAVService (Domain User)
* setspn -A DynamicsNAV/AVRVMNAV01:7046 AVR\DynamicsNAVService
* setspn -A DynamicsNAV/AVRVMNAV01.avr.dom:7046 AVR\DynamicsNAVService
* Trust this user for delegation to specified services only (also tested under all services)
Use Kerberos only
MSSQLSvc - AVRVMSQL01 - 1433
* UserAccountControl flags (17367552) - this was changed in ADSI Edit (and changed back as well for testing)
* Domain Policy Changes (based upon Kerberos documentation from Microsoft):
Act as part of Operating System
Impersonate a client after authentication

Specifics on setup - AVRVMSQL01:
* Trace Flag 4616
* xp_ndo_x64.dll registered
* Change Listener Permissions set for AVR\DynamicsNAVService

Specifics on setup - AVRVMNAV01:
Default Installation of NST - DynamicsNAV = Service Name
KB968189 installed (new SPN format that will be included with SP1)

Specifics on setup - AVRVMCLIENT01:
Default Installation of RTC - connecting to AVRVMNAV01.avr.dom/DynamicsNAV
KB968189 installed (new SPN format that will be included with SP1)

After all of this is setup - we're seeing the following error from System on the client machine:
The kerberos client received a KRB_AP_ERR_MODIFIED error from the server DynamicsNAVService. This indicates that the password used to encrypt the kerberos service ticket is different than that on the target server. Commonly, this is due to identically named machine accounts in the target realm (AVR.DOM), and the client realm. Please contact your system administrator.

On the AVRVMNAV01 box (Security Audit):
An account failed to log on.

Security ID: NULL SID
Account Name: -
Account Domain: -
Logon ID: 0x0

Logon Type: 3

Account For Which Logon Failed:
Security ID: NULL SID
Account Name:
Account Domain:

Failure Information:
Failure Reason: Unknown user name or bad password.
Status: 0xc000006d
Sub Status: 0xc000006a

Process Information:
Caller Process ID: 0x0
Caller Process Name: -

Network Information:
Workstation Name: -
Source Network Address: -
Source Port: -

Detailed Authentication Information:
Logon Process: Kerberos
Authentication Package: Kerberos
Transited Services: -
Package Name (NTLM only): -
Key Length: 0

This event is generated when a logon request fails. It is generated on the computer where access was attempted.

The Subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The Logon Type field indicates the kind of logon that was requested. The most common types are 2 (interactive) and 3 (network).

The Process Information fields indicate which account and process on the system requested the logon.

The Network Information fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The authentication information fields provide detailed information about this specific logon request.
- Transited services indicate which intermediate services have participated in this logon request.
- Package name indicates which sub-protocol was used among the NTLM protocols.
- Key length indicates the length of the generated session key. This will be 0 if no session key was requested.

And on the domain controller all success audits are working with Kerberos.

When looking at a wire capture of Kerberos packets, I do see that a TGS-REP that comes from the ADC is considered corrupted as the header checksum's are off. It looks like NAV requests a TGS-REQ and then the server replies with a TGS-REP for Kerberos - it is using Kerberos Version 5 as that comes standard with Windows Server 2008. All of the other machines look to not have any corrupted packets - I don't know if this is an issue or not but I am stating it in case anyone has any background.

I have also tried doing Local System/Network Service accounts, but still run into issues. It's almost as if the RTC is not getting the correct Kerberos ticket and is unable to decrypt packets. It then tries (every 10 seconds) to request a new ticket. Rebooting, using kerbtray, or any of the other utilities does not fix the issue.

I'm open to anything that people have for suggestions...It works fine in a 2 tier environment (NST and SQL on same box), but as this is a 180+ user roll-out, we are looking at using the NST (multiple ones for that matter).


- Scott
Scott Frappier
Vice President, Deployment Operations

Symbiant Technologies, Inc.


  • alexpeckalexpeck Member, Microsoft Employee Posts: 37
    Hi Scott

    Are you using fully qualified names in all the config files and SPNs? I have seen cases where DNS suffixes are appended in a strange sequence, causing the machine to resolve in the wrong domain, and consequently not match the SPN. You should be able to see the DNS suffixes listed on the DNS tab under advanced TCP/IP settings.

    I have also seen KRB_AP_ERR_MODIFIED arise from duplicate SPNs. If you haven't done so already, you can follow this guide to investigate: http://technet.microsoft.com/en-us/library/cc772897(WS.10).aspx.

  • Scott_FrappierScott_Frappier Member Posts: 90

    Appreciate your reply.

    The issue centered around the DelegationInfo key. The MSDN article did not have the information listed and I found an older post from you on MIBUSO regarding this issue. We added the DelegationInfo key and was able to connect in a Windows 2003 domain and in a Windows 2008 domain.

    The MSDN article that was in question was here:

    The installation help files have the documentation on this feature (from the RTM), but do not have the SPN updates as we're using the new SPN syntax. I'm not sure if this was removed from the MSDN article because SP1 is not requiring this key to be added, or if it was just missed.

    It's always fun to be "in the middle" between a hotfix and a new upcoming release - I'm just happy that it's resolved!


    - Scott
    Scott Frappier
    Vice President, Deployment Operations

    Symbiant Technologies, Inc.
Sign In or Register to comment.