Options

Problem with umlauts in RTC

mihail_kolevmihail_kolev Member Posts: 379
edited 2009-07-28 in NAV Three Tier
Hello there,
our project need to work in German lang. The problem is with the umlauts only in the RTC.
First, when i try to write some umlaut letters in name for ex. there is no problem - field is validated.
Next, when i see the new name in the list - it is just the regular chars.
When i open the card again, it is with regular chars.

In the classic client, everything is shown fine. I have made the regional settings. What could be the problem... any suggestions?

(sorry for image order... it is reversed :oops: )
-Mihail- [MCTS]

Answers

  • Options
    ara3nara3n Member Posts: 9,256
    Did you check the regional setting on service tier?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    mihail_kolevmihail_kolev Member Posts: 379
    Yes, but only the administrator acc. got the regional settings, do i have to change it for the domain account which run the service?

    I changed it - same situation :(

    Edit: If i write the umlauts in the Classic, then in RTC looks like the attachment.
    -Mihail- [MCTS]
  • Options
    ara3nara3n Member Posts: 9,256
    Did you change it in the computer where the service tier is running?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    mihail_kolevmihail_kolev Member Posts: 379
    Yes - it's a virtual machine, once changed for the administrator, and once for the domain account running the service.
    -Mihail- [MCTS]
  • Options
    kinekine Member Posts: 12,562
    Which Collation you are using on the SQL DB?
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • Options
    mihail_kolevmihail_kolev Member Posts: 379
    Latin1_General_CS_AS (SQL2008).
    -Mihail- [MCTS]
  • Options
    kinekine Member Posts: 12,562
    Which "Language for non-unicode applications" you are using on the server and on the client?
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • Options
    mihail_kolevmihail_kolev Member Posts: 379
    I think I got it - setting in attachment on service tier. I can't restart it right now, but i will share what the effect is.
    -Mihail- [MCTS]
  • Options
    mihail_kolevmihail_kolev Member Posts: 379
    Yes, that's it, thank you all :)
    -Mihail- [MCTS]
  • Options
    ara3nara3n Member Posts: 9,256
    Glad that you got it solved.
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
Sign In or Register to comment.