User cant apply vendor entries

bob_upbob_up Member Posts: 155
One user at one of our sites can no longer apply vendor entries. When she tries she gets the message "Application was successfully posted although no entries have been applied". This first became apparent when she posted a payment journal, which she had populated using the "Suggest Vendor Payments". Since then it appears that she cant apply posted vendor ledger entries either.

Other users can apply the entries which fail for her. She is not a new user and appears to be operating the function correctly. She has successfully posted applications in the past.

The currency on the payments and invoices are the same. The payments are dated more recently than the invoices. I mention this because I recall a problem with applying payments which predated the invoices.

Can anyone suggest what might be going wrong ?


  • AdamRoueAdamRoue Member Posts: 1,283
    Can she apply the failed entries after the failure?

    If she can then it is the process of the payment. I remember in one version if your focus was on the credit element in the line of the journal the application failed, so my guess would be it would be something in the process, but something minor causing the issue. Assuming of course you have made no rights changes or modifications recently. :D
    The art of teaching is clarity and the art of learning is to listen
  • bob_upbob_up Member Posts: 155
    Assume away ... :D
  • AdamRoueAdamRoue Member Posts: 1,283
    The time I had this I had to shadow the user, watch every mouse click and key stroke. I then deleted the payment journal and did it myself in the exact same fashion and it failed - it was to do with the order and where the focus ended up, and when they pressed OK - I think this was the key (sorry it was 3+ years ago) basically though the user was doing something ever so slightly different, and I had to watch her, compare it to my working way and work out what was wrong!
    The art of teaching is clarity and the art of learning is to listen
  • bob_upbob_up Member Posts: 155
    Thank you Adam. I have come across other similar tales in my research but this instance doesnt quite fit the same model. My user had the problem posting a payment journal which had been populated using the "suggest payments" routine. In that scenario the application is all done in the batch job. Furthermore she is an experienced user who has had no previous problems of this nature. Now she has consistent problems ...
  • bob_upbob_up Member Posts: 155
    I have now watched the user and I cant see anything wrong in what she is doing. I have also operated with her login and got the same results. This was using our dealer license and having given her superuser permissions. I have tried debugging through the process but cant spot where the problem lies. I would be really grateful for any suggestions ...
  • AdamRoueAdamRoue Member Posts: 1,283
    Well if she is an experienced user who never had problems, and now she does, ask her when this started - then have a look at the system changes at this time. This things do not just start happening there is always a cause, and where you have gone with this a change someone has made to the system is affecting this user.
    The art of teaching is clarity and the art of learning is to listen
  • jannestigjannestig Member Posts: 999
    Quick Question to ask.

    Which Version of NAV are you using there is a 2 logged issue on partnersource or customer source for this
    The link below for 3.7/4.0 matches your scenario of where the payment is posted before the invoice in which case you can use the following resolution

    To resolve this issue, apply the invoice to the payment after the payment is posted, and then post the application

    3.7/4.0 ... lknpovmylr

    Nav 2009 ... qltuqpnvxv
  • bob_upbob_up Member Posts: 155
    Unfortunately neither of these fit this user. They have V2009 but only the classic client.

    I hear what you are saying Adam and that is my position too but noone is aware of a change between last week when everything was fine and this monday when applications stopped working.

    The tantalising detail is that the same documents which generate the error for this particular user can be applied successfully by another user. It is making me look for factors which can be specific to a user, but I realise that may be a red herring ...

    Thank you all, again, for the suggestions ...
  • jannestigjannestig Member Posts: 999
    I tried the scenario you are suggesting on the VPC image of 2009.

    Did she try the following

    Select the Invoice VLE and apply it to the payment (Eg F9 on payment line),
    If fail
    Select Payment VLE and apply to invoice ?

    Last ditch effort was to have her log onto another pc with her id and try to post it there, you said you have tried this with her id but not if it was on another PC

    Last ditch effort would be Synch her permissions again then if still an issue remove her login from nav and set it up with permissions again
  • bob_upbob_up Member Posts: 155
    She has generated this message two ways. The first time was when she posted a payment journal. This had been populated using the 'Suggest Vendor Payments' batch job, so she didnt have any manual input into the application of entries.

    The second and subsequent errors were generated trying to apply posted entries. In those instances she positioned to the payment (or credit note) first, then selected to apply entries. She then used F9 to set the applies-to id on the invoice lines.

    I think we will give your other suggestions (resynching, creating a new login) a try.
  • matpodmatpod Member Posts: 16
    Just a thought, but may be worth a try....

    Ask the user to use a different client PC and try the same transactions. Perhaps some corruption in the ZUP file is causing the issue?
  • bob_upbob_up Member Posts: 155
    We have a solution :D

    Unfortunately my colleague took the 'throw everything at it' approach so I dont know exactly which thing was significant. We created a new login for the user and also deleted the zup file. Either one on their own might have resolved it. So it is a bit of an unsatisfying conclusion to the topic. Sorry.

    Thank you all again for your suggestions. It made the whole confusing incident so much less stressful.

Sign In or Register to comment.