Unable to connect to Service using FQDN but works with IP.

TonyHTonyH Member Posts: 223
edited 2009-04-04 in NAV Three Tier
Hi guys,

This issue is resolved, but in the interests of being pro-active, I thought I would post the symptoms and resolution here as a matter of archive.

I installed on Server 2008 SQL 2005 and NAV 2009 in a 2 tier architecture (DB and Nav Server Service on same machine) - This server we shall call NAV

If we ran the RTC from the server we could connect to "NAV\DynamicsNAV" without issue.

However when we ran the RTC from a TS setup the RTC would not connect to using the FQDN "NAV". However it would using the IP. This was a TS Application Server Role.

What then gets even more bizarre was that local XP Pro machines could connect fine with FQDN.

I have to say a lot of people got involved in this from Redmond to Fargo and Denmark.... And thanks to all of them they were awesome.

Here was the issue....

For some other reason I was having issues with the NAV Server Service Tier and to resolve that issue had set to LogOnAs to a DomainAdmin account, and the SQLSERVER Service was set to LogOnAs a specific "SQLService" domain account.

We set both back to "Network Service" (BuiltIn) and restarted it all and it worked fine using the FQDN.

The answer was incorrectly set SPNs for the DomainAdmin account, by setting back to builtin in worked fine. Because the account set as LogOnAs was domain Admin it was elevated beyond usual security and thus worked with IP.

See the following :-

http://technet.microsoft.com/en-us/libr ... 72897.aspx


I hope this helps anyone else who may run into this issue.

Sign In or Register to comment.