Options

Problems while edit Reports in Visual Studio

BubblemanBubbleman Member Posts: 10
edited 2009-03-04 in NAV Three Tier
Hallo together,

I have a, I think, big Problem. I wan´t to edit for example the "Sales - Order" Report and if I save the changes and go back to NAV, after the question about Import the new RDLC-File, I get the Error "The RDLC file is not a well-formed XML document."

This also happened when I only save the file in VS (or Editor) without taking any changes.

Could anybody help me? I try it with two completely different Systems, both with the same Problem. I use VS 2008 Pro SP 1 (with .net Framework 3.5 SP1).

Thanks for your help.
King Regards
Christian Maaß

Comments

  • Options
    ara3nara3n Member Posts: 9,256
    Find where the RDL is stored and open the file after you save it IN VS and see if you can open it in Internet explorer.
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    BubblemanBubbleman Member Posts: 10
    Hi together,

    we (a Microsoft Supportler and I) had solved the problem: It was the `ß` in my Windows Username.

    Thanks together
  • Options
    ara3nara3n Member Posts: 9,256
    thanks for sharing this. Was the solution to change your name from `ß` to ss?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    juanjuan Member Posts: 16
    Hello, I pass the same, I have the error "The RDLC file is not a well-formed XML document" and I can not fix it.
    I do not understand what the user, can you explain?

    Thank you.
  • Options
    BubblemanBubbleman Member Posts: 10
    I only changed my TMP-Dir in the Windows settings to one with no ß, so i hadn´t any further Problems.
  • Options
    juanjuan Member Posts: 16
    Sorry, but I do not understand what changed in the configuration of windows, I do not know is that TMP-dir and without ß?

    You can explain that. Thanks
  • Options
    BubblemanBubbleman Member Posts: 10
    My Name AND WINDOWS USERNAME is "Christian Maaß". So my standard Temp directory in Windows is C:\Users\Christian Maaß\Temp...
    But there is the Problem. If I changed a report in VS and try to bring it back to NAV, he can´t find the files, because NAV can only use Unicode and not the "ß" in my temp-path.

    I hope that you understand it now :) If not, I hope that anybody alse can explain it better than me here.
  • Options
    juanjuan Member Posts: 16
    Ok, now if I've heard, but that does not happen to me me.

    I do not know what to look.

    Anything else to check?

    thank you very much
Sign In or Register to comment.