Upgrade from 3.56 to 2.6 (F)- internal error 10005 module 19

HH85HH85 Member Posts: 3
edited 2012-08-06 in Navision DOS
I am upgrading a 3.56 database to 2.6(F)
But i can't restore the backup file. It keeps telling me about an internal error 10005 in module 19.
Anyone know how to fix this?

Your help is appreciated
Thanks in advance.


  • David_SingletonDavid_Singleton Member Posts: 5,479
    Is this actually Internal Error 1005 in Module 19 (maybe one zero too many?) 19-1005 #Err_DB_UnknownFieldNo DB_AErr

    Here is a list of Module 19 errors:
    NAV internal error messages - Dynamics

    But back to the actual issue. I know that it should be possible to import BAK files into all versions of Navision, but I do remember having some problems with later versions of Navision. (after 2.01 when they changed the index on Object name to be unique for SQL, and after they increased record size to 4k)

    What I would try is to import the backup into a version 1.30 or 2.00 database, then export as an FBK and import that into 2.60.

    Another possibility is some add on that adds fields in a range (in the DOS app) that is not supported in the Financials license.
    David Singleton
  • David_SingletonDavid_Singleton Member Posts: 5,479
    Actually I also remember an issue with the way they map fields into the 50,000 range. Look for Fields that are out of the normal 1-999 range.
    David Singleton
  • HH85HH85 Member Posts: 3
    Thank you David
    I'll try your suggestion and post the results here as well.
  • NaviBoogieNaviBoogie Member Posts: 6
    Hi I am now struggling with this conversion for many many hours. So far without results... ](*,)

    I have tried to upgrade in version 2.0, 2.01, 2.60 1.30...

    The errormessage I get is still: Internal Error 10005 in Module 19. It is 10005 and not 1005 ... ?

    Then I have tried a read-out tool N3xx3NF, DOS based.

    When I try to extract the DB with this I get:
    Internal Error: 47-1
    Text no. 20000-1 does not exist in the .stx file

    Can anyone help us??

  • David_SingletonDavid_Singleton Member Posts: 5,479
    I wonder since module 19 errors relate to the Native database, what about trying a restore to a SQL database?
    David Singleton
  • NaviBoogieNaviBoogie Member Posts: 6
    I will give it a go...

    Thanks David
  • David_SingletonDavid_Singleton Member Posts: 5,479
    Since you are getting STX errors, I am also curious which language verison you are using.

    I suggest to use W1 maybe its is an issue with fields that are out of your license range, and the particular error message is not in the STX file for your country version.

    By the way, I dont think Text 20000-00001 exists in any stx file, but I may be wrong.
    David Singleton
  • NaviBoogieNaviBoogie Member Posts: 6
    I am working from Danish to Danish.

    Still no luck. I am making a copy of the database anew - I am thinking the other could be corrupted.

    I will try also to import it in a w-version..

    Its a hard nut for me...

    I get an error, when i import the copy of the company with application objects in an empty database in 3.56A:

    'Integer divided by zero' ...

    It is in no 113 - Sales invoice line.

    Could this be the problem?
    If so, how could I solve this?
  • Minu63Minu63 Member Posts: 16
    I got just now the same error message and found your topic here. It seems to me, that this problem isn't answered here, but if you still have the same problem - you can find the solution here (from Andreas Vogel): viewtopic.php?f=2&t=10225&hilit=10005

    He wrote:
    We also tried with Version 2.00, 3.60, 3.70, always the same error.
    Then we tried with the client monitor. We found the table, which produced the error. We restored the backup in a 3.56 database. Then we deleted all flow-fields from this table and made an new backup. Then the restore worked without a error.

    In my database it was table 27 "Item" which caused the error. After deleting all FlowFields and a new backup I could import the 3.56 data without any problems :)
Sign In or Register to comment.