Options

General Journal / Another error during posting

ToruToru Member Posts: 20
When I trying to post some general journal entries, I get the following error message :

"1 posted on 01/31/08 includes more than one customer or vendor. In order for the program to calculate VAT, the entries must be seperated by another documents number or by an empty line."

Lots of customers, just one bank account and some other accounts were written in the journal. I dont want NAV to calculate VAT for any of these lines.

What should I do?

Comments

  • Options
    JaspreetJaspreet Member Posts: 10
    Hi Toru

    This case arises when there journal entries have customer and vendors and along with it VAT amounts. But as you mentioned that no VAT is to be calculated on these entries, therofore you need to enure that the following columns in the journal lines do not have any values:
    - VAT Bus. Posting Group
    - VAT Prod. Posting Group
    (Do a 'show column' and make these fields visible and delete any data in them) Now the journal can be posted.
  • Options
    ToruToru Member Posts: 20
    Jaspreet wrote:
    Hi Toru

    This case arises when there journal entries have customer and vendors and along with it VAT amounts. But as you mentioned that no VAT is to be calculated on these entries, therofore you need to enure that the following columns in the journal lines do not have any values:
    - VAT Bus. Posting Group
    - VAT Prod. Posting Group
    (Do a 'show column' and make these fields visible and delete any data in them) Now the journal can be posted.

    Hi Jaspreet;

    Firstly; thanks for the response.

    I checked again that situation. But all the entries has no value for these columns. In this case; Nav shouldnt try to calculate VAT Amounts for entries.

    Any other idea?

    Thanks again.
  • Options
    NoelineNoeline Member Posts: 54
    Hi there

    Make sure the General posting Type is blank

    Regards - Noeline
  • Options
    ToruToru Member Posts: 20
    Noeline wrote:
    Hi there

    Make sure the General posting Type is blank

    Regards - Noeline

    If I do that; that is the message I get while posting :

    "Gen. posting type must not be in Gen. Journal Line Journal Template Name='GENEL', Journam Batch Name='TORU', Journal Line No.='10000'"

    Any other idea please??
  • Options
    DeepDeep Member Posts: 569
    Toru wrote:
    "Gen. posting type must not be in Gen. Journal Line Journal Template Name='GENEL', Journam Batch Name='TORU', Journal Line No.='10000'"

    This message you get when you have the Posting groups for the G/l account filled in the Journal Line. These automatically get populated in the journal line from the account card when you select the account containing posting groups.

    When the posting groups are defined, the system asks for the General Posting Type. Make sure you dont have any posting groups (VAT) selected to avoid this error.

    You can check.
    Regards,

    Deep
    India
Sign In or Register to comment.