Options

Send to Excel formats numbers as text

NagiNagi Member Posts: 151
Hello,

One of our customers is experiencing a problem with the "Send to Excel" option in NAV 5.0 (SQL database). For some reason or other, Excel (2003 version) keeps formating 98% of all numbers as text. We don't get the same error when doing the same in our own copy of the customer's database. The only difference is that we have Excel 2007 installed.

Is there anybody who could shed some light on this issue? Any help on this would be greatly appreciated.

Cheers!

Answers

  • Options
    NagiNagi Member Posts: 151
    The culprit seems to be the empty space before the one thousand mark; so that any numbers between 1 and 999 are formated as numbers, but 1 000 and above are formated as text.

    :-k :-k :-k
  • Options
    kinekine Member Posts: 12,562
    This is one "side effect" of Local settings of the Operating system. You can set the thousands separator there. In some cases there is space and sometime there is "fixed space" (it seems like common space but will not be divided at the end of line when formating paragraph). Just enter there the space (by spacebar), click OK, and try it again.
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • Options
    NagiNagi Member Posts: 151
    Thanks, Kine!

    =D> =D> =D>

    We actually became aware of this ourselves when we noticed that one of my colleagues had the same problem. Changing the thousand seperator to a punctuation mark fixed the problem.
  • Options
    kinekine Member Posts: 12,562
    You are welcome...

    This is common problem in Czech Republic. Our local settings are using the fixed space and this inconsistency in NAV is pain...
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
Sign In or Register to comment.