error (87): The parameter is incorrect

joemoujoemou Member Posts: 3
edited 2006-07-12 in Navision Attain
I m new to Navision. After I completed the client installation successfully, I tried launching it. Then it gives the error dialog: "The operating system returned the error (87): The parameter is incorrect. OK?" and of course nothing was launched after I press OK. :(

I tried uninstall, reboot, clean-up the directory, 100 times in any combinations and sequences. Still not work. Can anyone help?

The problem happens to some machines but not to others. All are winxp.



  • Smashed_PumpkinSmashed_Pumpkin Member Posts: 47

    Are you on a domain? If so, does the user you are logged in as have access to the local computer? Go to Control Panel>User accounts and see if the user/domain is on the list. If not, add the user to the list (give them Power User rights), log out, log back in, and try again.

    We had a similar problem and that's how I cured it. Hope this helps :)
  • joemoujoemou Member Posts: 3
    The machine is not joining a domain, and I'm already using the Local Administrator account to do everything :(
  • GoMaDGoMaD Member Posts: 313
    Have you tried to start the fin.exe or the finsql.exe directly from windows explorer?

    Maybey you are trying to start the client from a shortcut which has some extra paramaters in the command line.
    Now, let's see what we can see.
    Everybody on-line.
    Looking good!
  • David.InformaticaDavid.Informatica Member Posts: 6
    Check the parameters of the server. The Cache have to be under 900 MB. Try to put server cache=800000 :shock:
  • akasererakaserer Member Posts: 6
    I got this message also when starting a DB without a server just by opening the DB via File - Database - Open.

    After that I started the DB with a Navision Server - connected to this server. Then it was 'Recovering list of free blocks'.

    After that the Db was working on both modes: starting via server and also via 'doubleclick'.

Sign In or Register to comment.