Options

Windows Authentication Error Message

dabeldabel Member Posts: 44
edited 2013-06-29 in SQL General
I am receiving the following error message while trying to login with windows authentication (SP2). I have created the stored procedures and copied the xp_ndo.dll file into the proper location. Has anyone ever seen this before?

The following SQL Server error(s) occured:

17750,"42000",[Microsoft][ODBC SQL Server Driver][SQL Server]Could not load the DLL xp.ndo.dll, or one of the DLL's it references. Reason:5(Access is denied.).

SQL:
INSERT INTO [#$ndo$groups] {CALL [master]..[xp_ndo_enumusergroups](?,?)}


Thanks

Comments

  • Options
    ara3nara3n Member Posts: 9,256
    rightclick on the xp.ndo.dll and goto properties. on security tab make sure everyone is added.

    Also the dll is in the binn folder ?
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    kinekine Member Posts: 12,562
    the name of the library is xp_ndo.dll not xp.ndo.dll may be this is the problem... ;-)
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • Options
    ara3nara3n Member Posts: 9,256
    didn't see it. :|
    Ahmed Rashed Amini
    Independent Consultant/Developer


    blog: https://dynamicsuser.net/nav/b/ara3n
  • Options
    darshanmdarshanm Member Posts: 280
    This is a common problem.

    Go to NAV product CD and open SQL_esp folder.
    there you open readme.txt file. you will find the solution.
    Darshan Mungekar
    Senior Consultan
  • Options
    dabeldabel Member Posts: 44
    FYI...

    The xp.ndo.dll was a typo on my part! :oops:

    Thanks ara3n,

    The security properties of the dll under the binn folder was the problem. For some reason, simply copying the xp_ndo.dll file and overwriting the existing one did not build the correct security properties. So I deleted the file and then ran the xp_ndo.exe and unzipped it to this folder and that did the trick.

    Thanks everyone for your replies.

    Happy New Year!
  • Options
    krikikriki Member, Moderator Posts: 9,098
    [Topic moved from Navision forum to SQL General forum]
    Regards,Alain Krikilion
    No PM,please use the forum. || May the <SOLVED>-attribute be in your title!


  • Options
    ROKROK Member Posts: 9
    I was getting this same error with reason 5: gave all the permissions to the related user invain until i placed the DLL in the bin folder of SQL.

    Just wondering why this strictly worked in the bin folder.

    Ronald.
Sign In or Register to comment.