Options

Error receiving Attachments with mail in other than Outlook

RolfGardeRolfGarde Member Posts: 15
We create a PDF document using a pdfprinter from NAV 5.0.

We use CU 397 to create an e-mail with this PDF-file as an attachment. We set the mail to Open in outlook so the user can add more text if necessary.

When the receiving end uses outlook or GMail this mail incl. attachment is received without problems. When the user has Outlook Express or another mail-client the mail is received, but the attachment is received as Winmail.dat - and this attachment is not possible to open with Acrobat reader.

If we manually open af new mail from outlook and attach the same PDF-File - it is received without problems. So the error must be in the mail that is generated from NAV.

I am all out off Ideas - so any ideas are velcome.
Mvh
Rolf Garde

Comments

  • Options
    todrotodro Member Posts: 117
    RolfGarde wrote:
    We create a PDF document using a pdfprinter from NAV 5.0.

    We use CU 397 to create an e-mail with this PDF-file as an attachment. We set the mail to Open in outlook so the user can add more text if necessary.

    When the receiving end uses outlook or GMail this mail incl. attachment is received without problems. When the user has Outlook Express or another mail-client the mail is received, but the attachment is received as Winmail.dat - and this attachment is not possible to open with Acrobat reader.

    If we manually open af new mail from outlook and attach the same PDF-File - it is received without problems. So the error must be in the mail that is generated from NAV.

    I am all out off Ideas - so any ideas are velcome.
    Hi,

    change the format in Outlook Express in the Menu "Format" to "Text-Only". I'm not aware of a MAPI property which could be used inside codeunit 397 to get this done automatically
    Torsten
    MCP+I, MCSE NT, Navision MCT (2004,2005)
  • Options
    RolfGardeRolfGarde Member Posts: 15
    todro wrote:
    change the format in Outlook Express in the Menu "Format" to "Text-Only". I'm not aware of a MAPI property which could be used inside codeunit 397 to get this done automatically

    The problem is that the feature is used for sending PDF-files all over the world - and to new partners each day. So it is not possible to change settings on the receivers side. It must be done from the NAV-side.

    I should think that there must be a setting in til outlook library that could solve this problem - but my knowledge about that is none to speak off.
    Mvh
    Rolf Garde
  • Options
    David_SingletonDavid_Singleton Member Posts: 5,479
    RolfGarde wrote:
    todro wrote:
    change the format in Outlook Express in the Menu "Format" to "Text-Only". I'm not aware of a MAPI property which could be used inside codeunit 397 to get this done automatically

    The problem is that the feature is used for sending PDF-files all over the world - and to new partners each day. So it is not possible to change settings on the receivers side. It must be done from the NAV-side.

    I should think that there must be a setting in til outlook library that could solve this problem - but my knowledge about that is none to speak off.

    Try this:

    OSendMail.BodyFormat := 1;
    
    David Singleton
  • Options
    todrotodro Member Posts: 117
    RolfGarde wrote:
    todro wrote:
    change the format in Outlook Express in the Menu "Format" to "Text-Only". I'm not aware of a MAPI property which could be used inside codeunit 397 to get this done automatically

    The problem is that the feature is used for sending PDF-files all over the world - and to new partners each day. So it is not possible to change settings on the receivers side. It must be done from the NAV-side.

    I should think that there must be a setting in til outlook library that could solve this problem - but my knowledge about that is none to speak off.
    You only have to change that on the sender side and as you said, you send the mail in interactive mode, so the Outlook Express client opens.

    Try the BodyFormat property as David suggested. If this property is mapped to the MAPI Attachment type, this might do the trick, changing from InText-Attachments to AddOn-Attachments which no longer cause the RTF format to be used.
    Torsten
    MCP+I, MCSE NT, Navision MCT (2004,2005)
  • Options
    RolfGardeRolfGarde Member Posts: 15
    OSendMail.BodyFormat := 1;
    

    That didn´t do the trick :-(

    We use Outlook 2003 to send - and it is received without errors in Outlook 2003 and Gmail. It is received as Winmail.dat in Outlook Express, Some Linux Mail klient, Some Danish Webmail from TDC.

    I am all out of ideas. Does anyone have some?
    Mvh
    Rolf Garde
  • Options
    todrotodro Member Posts: 117
    RolfGarde wrote:
    OSendMail.BodyFormat := 1;
    

    That didn´t do the trick :-(

    We use Outlook 2003 to send - and it is received without errors in Outlook 2003 and Gmail. It is received as Winmail.dat in Outlook Express, Some Linux Mail klient, Some Danish Webmail from TDC.

    I am all out of ideas. Does anyone have some?
    did you also try to change the format manually before sending as I suggested ?

    Are the attachments inline attachments ? If so, then automatically RTF/HTML format will be used to create the links.
    Torsten
    MCP+I, MCSE NT, Navision MCT (2004,2005)
  • Options
    RolfGardeRolfGarde Member Posts: 15
    Still didn't work. Only Outlook and Gmail can receive the attached documents correct.

    I will now try to contact Microsoft
    Mvh
    Rolf Garde
  • Options
    anagha123anagha123 Member Posts: 1
    Hi Rolf, I am facing similar problem...have you got any solution for this?
  • Options
    Johnny_ReggaeJohnny_Reggae Member Posts: 63
    Did you find any solution to this problem ?
  • Options
    RolfGardeRolfGarde Member Posts: 15
    Not really.

    But mail me, and I will return the "the casefiles".

    - Rolf
    Mvh
    Rolf Garde
  • Options
    openventureopenventure Member Posts: 1
    I have the same problem and I'm thinking it's better to use another Automation instead of the one used in cu 397.

    Wich one can I use?
  • Options
    Alex_ChowAlex_Chow Member Posts: 5,063
    Same problem here even in NAV 2009 R2. Any solutions to this?
Sign In or Register to comment.