Windows Logins - Only Super Works [solved]

geri79geri79 Member Posts: 105
edited 2007-07-24 in SQL General

using Nav4 SP2.
I wantt to use windows logins. I have a AD group with my users in this group. I have the group and the users in Nav in the windows login table. Both users and group SQL role is public.

If I assign "Super" to a users or to the group, everything works fine.
IF I assign other roles (and not super) it doesn't work.

I tried the assigned set of roles with a DB login and it works.
I did not forget to synchronize.

I did not have extende procedure "xp_ndo_enumusergroups" and before installing it even the super windows users did not work, but now yes.
I am using SQL 2000 SP3a.

Any ideas?


  • kinekine Member Posts: 12,562
    And the error message says what?
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • geri79geri79 Member Posts: 105

    You do not have permission to access [tablename] table. Contact your admin...
  • krikikriki Member, Moderator Posts: 9,079
    [Topic moved from Navision forum to SQL General forum]
    Regards,Alain Krikilion
    No PM,please use the forum. || May the <SOLVED>-attribute be in your title!

  • bbrownbbrown Member Posts: 3,268
    geri79 wrote:

    You do not have permission to access [tablename] table. Contact your admin...

    Which table is referred to in the error? Is permission granted to that table by one of the roles assigned to user?
    There are no bugs - only undocumented features.
  • geri79geri79 Member Posts: 105
    All tables I want to access. I tested the role with DB Users and everything works fine.
  • geri79geri79 Member Posts: 105
    edited 2007-07-24
  • geri79geri79 Member Posts: 105
    Shame on me.
    Error was in my assigned role.

    I have a user-A what has only standard roles and one empty new role. With a copy script I copied all the permissions of his standard roles in the new role and then assigned this new role (kind of: my company manager role) to my AD group.

    Problem then was that the copy script had an error and did not copy everything. I did my test as DB user test always with this user-A and this worked (because had all roles). My windows users had just the copied permissions and something was missing.

    Now everything is fine.
Sign In or Register to comment.