HELP: A 'S' was expected here Error

ArhontisArhontis Member Posts: 667
Hi all HELP!!! ](*,) ](*,) ](*,)

I am trying to login with windows auth in sql server 2000 with nav 4.0 sp1 in an existing database and server that a few minutes ago used to work and I get the message "A 'S' was expected here." and returns to the database connection dialog...

Users already connected in the database and server work ok, but if they close the application and open it again, then it doesn't open!

Has anyone seen that before?!?

Best Answer


  • Options
    krikikriki Member, Moderator Posts: 9,090
    This lets me think you have in the shortcut something like
    NTAUTHENTICATION=S??? as parameter (or another parameter with =S???).

    Use "NTAUTHENTICATION=1". This is language independent.
    Regards,Alain Krikilion
    No PM,please use the forum. || May the <SOLVED>-attribute be in your title!

  • Options
    ArhontisArhontis Member Posts: 667
    No, no... No shortcut used... Only the File->Database->Open dialog...
    (And when I use a shortcut I always use the NTAuthentication=1)
  • Options
    WaldoWaldo Member Posts: 3,412
    Something changed in codeunit 1?

    Can they log into the database? (so it's only when logging into company).

    Is it possible to run the debugger?

    Eric Wauters
    MVP - Microsoft Dynamics NAV
    My blog
  • Options
    ArhontisArhontis Member Posts: 667
    I have already tested enabling debugger and break on triggers also, but it doesn't go through any code. Not even to reach cu1 yet...

    Maybe it is on the domain controler and the authentication, because I can login with database authentication or it is in the extended stored procedures...

    I have notified the IT dept to check the domain and the in general if there is an error there...

    Any more ideas? I am going crazy...
  • Options
    ArhontisArhontis Member Posts: 667
    It's ok now...

    I opened the Windows access control table with enterprise manager and saw that there was a record with no Login SID. I deleted that record and it worked just great!

    Thanks kriki,Waldo for the fast reply and for your effort to help me and especially wakestar who pointed at the right direction... :D \:D/ =D> =D>

    Really thanks guys... I appreciate it... :D

    I traveled 50 km through Athens in 30 minutes to come and see in person what was going on... lol
  • Options
    Troubles_In_ParadiseTroubles_In_Paradise Member Posts: 588
    Today we tried to open a 4.01 db with the new 2009R2 Classic Client and it gave back the same error.
    Also in this case the problem was records inserted into the windows login.
    After adjusted them we were able to open the db.
    Thank you for sharing :thumbsup:.
    It works as expected... More or Less...
  • Options
    jppatakijppataki Member Posts: 1
    This is now a quite older thread but it saved my day!
    I had the same problem in NAV 2009 R2 i was editing a user profile asked to synchronize that single logon and got (in portuguese "era esperado um ‘S’") a "'S' was expected error".
    I then got into this thread and made a select in the "Windows Access Control" table and discovered that the last line was with an empty SID, I placed the SID of the user that I wanted to have access and "voilá". Thanks Arhontis! PIGS Rule!
Sign In or Register to comment.