NAS 3.7b does not work with Client Data 3.7b v19868

HushdontspammeHushdontspamme Member Posts: 56
Hi

We have installed NAS from the 3.7b CD - configured the parameters for ADCS (SQL & TCP) - but when starting the NAS, the event log for NAS-SQL says database is a another version, cannot load etc..

In the Navision clients it is 3.7b 19868

If i change the "databaseversionno" field in table $ndo$dbproperty from 18 to 17, the NAS works. But because clients are on Nav 3.7b 19868 it converts the "databaseversionno" field back to 18 when logging in.

I don’t know how the end user got version 3.7b 19868. Is there a similar version for NAS / ADCS?

The database is SQL 2K

Any help will be appreciated

Comments

  • kinekine Member Posts: 12,562
    It seems like you are using NAS 3.70A instead 3.70B... try to uninstall/install the NAS once again, check the NAS path in registry, if it is pointing to correct folder... (do not forget to delete rest of the folder after uninstall)
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • HushdontspammeHushdontspamme Member Posts: 56
    Hi

    We have installed NAS using 3.7b from the CD.

    This is a clean installation. I have even got the same problem on my Virtual server (clean installs - restored database).

    What should i be checking in the registry?

    Regards

    J
  • DenSterDenSter Member Posts: 8,304
    I've had issues like that with 3.6 and 3.7, for some reason those versions were very picky about build numbers.

    To me it sounds like you have a cd that was created from the original product cd, and manually 'enhanced' with a hotfix that was not applied to the NAS executables. I would log onto partnersource and get a clean product cd, and try again.
  • kinekine Member Posts: 12,562
    I checked the version of fiels with the Hushdontspamme, he is trying to use update 1 for 3.70B now...
    Kamil Sacek
    MVP - Dynamics NAV
    My BLOG
    NAVERTICA a.s.
  • HushdontspammeHushdontspamme Member Posts: 56
    Hi

    With Kine help, we have managed to resolve the issue. The problem was that the client and database was on version 3.70.2.19868

    The NAS version from 3.7b CD is version 3.70.2.19516

    You need to download 3.70.B Update 1.zip for NAS and extract the files to the NAS folder if you clients and Db is running on 3.70.2.19868.

    big thanks to Kine

    Regards
  • DenSterDenSter Member Posts: 8,304
Sign In or Register to comment.