problem connecting to biztalk

mamamama Member Posts: 7
edited 2006-05-16 in Navision e-Commerce
I'm trying to send a order from navision via biztalk.

Biztalk together with commerce gateway request server is located on one computer and navision and NAS on another computer.

when I send a order to biztalk on the navision computer a error message occurs saying that it couldn't connect to the biztalk server

it seems that the order message is reaching the biztalk-computer because the event viewer on the biztalk computer says:

The Messaging Engine failed to register the adapter for "CommerceGateway" for the receive location "CG://Navision_to_CommerceGateway". Please verify that the receive location is valid, and that the isolated adapter runs under an account that has access to the BizTalk databases.

I tried register the request server adapter by running registeradapter in the commerce gateway request server folder but i get a error message there to saying:

Commerce Gateway Request Server adapter has already been registered.
Adding the adapter to the server...
Failed to add adapter to the server, reason: Failed to read value for "SendHandlerPropertiesXML" key while reading transport configuration from registry.
Failed to read value for "ReceiveHandlerPropertiesXML" key while reading transport configuration from registry.
The system cannot find the file specified.

Anyone who can help me?

best regards
mama

Comments

  • mamamama Member Posts: 7
    never mind..I solved the problem

    thx anyway
  • DenSterDenSter Member Posts: 8,304
    How did you solve your problem?
  • mamamama Member Posts: 7
    it's only half fixed we realized now, one of the problems occured due to an installation of NAS on the biztalk computer, the Biztalk computer seemed to reject the message. We got the message when trying to send a file and when trying to send to another navision.
    we re-installed everything (cg request, biztalk and sql 2000), thinking we might have messed up the orchestrations.
    now we can send a file converting it to xml in a specific receive folder on the Biztalk computer, just having alittle problems on sending an PO from our retail company to "whole".

    trying to find the correct parameters think we have som problems with authority, but at least we got it working alittle bit now.
Sign In or Register to comment.