Error after installing Employee Portal

stscatstscat Member Posts: 4
edited 2006-04-20 in Navision e-Commerce
When I go to the Home Page of NEP Demo, I reveive this error:

"Object reference not set to an instance of an object"

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[NullReferenceException: Object reference not set to an instance of an object.]
Microsoft.Navision.EmployeePortal.WebPartLibrary.DetailPart.OnPreRender(EventArgs e) +124
System.Web.UI.Control.PreRenderRecursiveInternal() +62
System.Web.UI.Control.PreRenderRecursiveInternal() +125
System.Web.UI.Control.PreRenderRecursiveInternal() +125
System.Web.UI.Control.PreRenderRecursiveInternal() +125
System.Web.UI.Page.ProcessRequestMain() +1499

I find a message in nep_request_queue with destination DIRECT=OS:web01.gsistema.local\private$\nep_request_queue
(my server name is WEB01)

The installation has been made using MS documentation and posts existing in this site

I receive same error even if I try to add an Emplyee Portal Web Part to an existing site.

Other Sharepoint sites work fine.

Any suggestion?



  • IHateLinuxIHateLinux Member Posts: 223

    is the NAS running properly?
    Has the NAS connected to the database?
    Is the NAS configured to run NEP Frontend processing?

    Because it seems that the request message is not processed by the NAS.
    Either because the NAS is not running or because the message could not be send to the destination queue.

    Perhaps you may post a brief description of your system environment (where is NAS, SharePoint, Machine Names, IPs,...)

  • stscatstscat Member Posts: 4
    Sorry but I was out of company!

    I tried 3 differents configurations:
    1) NAS + Navision installed in Windows XP and SharePoint installed in W2003
    2) Navision installed in Windows XP and NAS + SharePoint installed in W2003
    3) Navision + NAS + SharePoint installed in W2003

    I tried with Sql and native DB

    SharePoint is installed with S.P.2 and I tried with a Virtual Machine and also with a server; the Virtual Machine uses DHCP, but in web.config I use the computer name and not the IP; in the server I tried also using the IP (I saw an example in this forum) but always same error.

    I have SharePoint in English with Italian language pack

    NAS is running (I tried also with another parameter and a dedicated codeunit to test it)

    I made a lot of tests and only a time I saw a message in reply queue, but I had always the same error.

    I use the default web site extended in english language in SharePoint; so when I go to the site I can choose NEP demo; SharePoint creates the site normally.

    I don't use encription and so I didn't use Navision Key Exchange Management.

    I created backend key-par.

    Do you need other informations?

  • stscatstscat Member Posts: 4
    I solved reinstalling SharePoint!
    I don't know the reason...except the Employee Portal site my SharePoint sites worked normally.

    Anyway ... thanks

Sign In or Register to comment.