Error in Invoke-NAVApplicationDatabaseConversion for Azure SQL

ChenjeraiChenjerai MaltaMember Posts: 5
Hi,

I am upgrading BC15 database to BC17. I am getting the following error when I run the Invoke-NAVApplicationDatabaseConversion command:

Invoke-NAVApplicationDatabaseConversion : The database create operation failed due to the following error returned by SQL
Server:
Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
The statement has been terminated.

I can access the Azure SQL db from the same machine (using ssms and powerhsell command when I am working in BC15). Has anyone ever faced this issue? Any suggestions on how to resolve it?


Regards,

Chenjerai Madziwa
Cool

Answers

  • NicolaiHNicolaiH Member Posts: 23
    Hi Chenjerai

    Did you ever find a solution for this?

    I am getting the same error when trying to upgrade fra BC15 to BC18 also on Azure SQL. My database is only 546 MB. I have previously upgraded successfully from BC17 to BC18 on a much larger database.

    Best regards
    Nicolai Hansen
  • NicolaiHNicolaiH Member Posts: 23
    I tried running the same command again and again while searching for a solution. The 7th time I ran it the conversion completed successfully. Not much of a solution, but possibly helpful for some?
Sign In or Register to comment.