BC140 Start-NAVServerInstance: "The system is currently updating, try to connect later"

MipsMips Member Posts: 3
edited 2020-06-16 in NAV Three Tier
We have four NAV servers. After a restart, we have the following warning on the heavy load NAV servers for about half an hour when we try to connect:

Microsoft Dynamics 365 Business Central
The system is currently updating, try to connect later

Can we make changes in the Configuration, or what is the problem?


  • HeinrichHeinrich Member Posts: 7
    Hi Mips,
    did you find a reason for this or a solution?
    This week a customer complains about the very same thing. They restart NST at 3 am and get the message around 6 am when the first users try to connect. The message disappears after 10 - 30 minutes - but 'til that they can't work...
    THX Heinrich
  • MipsMips Member Posts: 3
    edited 2020-10-09
    Hi Heinrich,
    the problem is resolved. It was a bug by Microsoft. They fixed it in CU15.

    As workaround you can try this:

    1. Change / import table(s) with Sync option choose “Later”.
    2. Run the following PS cmdlet: Sync-NAVTenant BC140 -CommitPerTable -Mode Sync
    3. At this stage the Database will be in status “OperationalSyncInProgress” and your RTC and Web client will not be able to connect as before.
    4. Wait 1 minute and then restart the NAV Service.
    5. When the service is available again the database will be showing “Operational” and the table change will be fully synchronized. Users will be able to connect with the RTC as normal.
  • SunsetSunset Member Posts: 194
    Mips wrote: »
    Hi Heinrich,
    the problem is resolved. It was a bug by Microsoft. They fixed it in CU15.

    Do you have any link/documentation on this? One of our install BC14 CU7 just started having this problem, 1 time last week and again today. All modifications are done by extensions, so there are no table changes in the old development system.
    Going over the documentation for CU15, I cannot find anything referring to this, so I am hoping that you might have something?
    Don't just take my word for it, test it yourself
  • MipsMips Member Posts: 3
    No, we have no Documentation on this. But we have placed a support request with microsoft. After a quarter of a year they told us that it is solved with CU15, and for us it worked.
  • RobJelRobJel Member Posts: 1
    We registered the same issue last week with CU20. Anybody else?
Sign In or Register to comment.