BC14 CU11 App Install Error

I am facing issue when I try to install Suretax app on BC14 CU11.

I am able to install app on Cronus BC14 CU11 Database but I am getting error as shown in below snapshot when I tried to install on Customer Database.

I have already generated symbol for all objects and resolved compilation error. Any help is appreciated.

Note: Customer Database is upgraded from 2009 R2 to BC 14 CU11.
PS C:\Windows\system32> Publish-NAVApp -ServerInstance bc140 -Path "C:\CCH App Install\CCH Incorporated_CCH SureTax Base for Dynamics Business Central_14.0.9.2020061801.app" -SkipVerification
Publish-NAVApp : Extension compilation failed
error AL1024: A package with publisher 'Microsoft', name 'System', and a version compatible with '14.0.0.0' could not
be loaded. Symbols for the requested app System by Microsoft 14.0.0.0 could not be found in the database
Codeunits/Cod14083512.CCHVersionManagement.al(18,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083512.CCHVersionManagement.al(75,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083512.CCHVersionManagement.al(88,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083512.CCHVersionManagement.al(101,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083512.CCHVersionManagement.al(114,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083513.CCHBaseSecurityRoles.al(20,22): error AL0185: Table 'Permission Set' is missing
Codeunits/Cod14083513.CCHBaseSecurityRoles.al(48,19): error AL0185: Table 'AllObj' is missing
Codeunits/Cod14083513.CCHBaseSecurityRoles.al(70,21): error AL0185: Table 'Permission' is missing
At line:1 char:1
+ Publish-NAVApp -ServerInstance bc140 -Path "C:\CCH App Install\CCH In ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (:) [Publish-NAVApp], InvalidOperationException
+ FullyQualifiedErrorId : MicrosoftDynamicsNavServer$bc140/nav-systemapplication,Microsoft.Dynamics.Nav.Apps.Manag
ement.Cmdlets.PublishNavApp

Best Answer

Answers

  • ShaiHuludShaiHulud Member Posts: 138
    As the error says, are you sure "System.app" is installed? Does it show up when you run the following command?
    Get-NAVAppInfo -ServerInstance bc140
    
    Arturas Kulsinskas
    NaviLogic

    All opinions expressed are my own and are not reflective of my employer
  • Dynamics2018Dynamics2018 Member Posts: 5
    edited 2020-09-17
    Thank you for your reply.

    No it does not show System.app when I run command that you have mentioned.

    Also, Get-NAVAppInfo -ServerInstance BC140 -symbolonly also does not show anything on Customer database which is upgrade from 2009 R2 to Business Central. While, the same shows result on Cronus Base BC14 CU11 Database.

    Customer is on BC14 CU11 on-premise version.
  • Dynamics2018Dynamics2018 Member Posts: 5
    Thank you for your reply.

    Yes, I have resolved the problem using the same way as you described.
  • PistlePistle Member Posts: 1
    The long file and folder name structure caused the problem in combination with 7zip. :D
    I unzipped the file 'CU 01 Microsoft Dynamics 365 BC Spring 2019 Update On Premise NL.zip' in a new folder 'CU 01 Microsoft Dynamics 365 BC Spring 2019 Update On Premise NL' and then unzipped 'Dynamics.365.BC.32615.NL.DVD.zip' in a subfolder 'Dynamics.365.BC.32615.NL.DVD'.
    I used 7zip to do this, and this gave no errors: all files seemed to be unzipped without a problem.
    When doing the same with windows zip, an error occurred saying 'Path too long'. After unzipping in a new folder with a shorter folder-name structure, the installation worked fine.
    Strange enough, in windows explorer the folders and files extracted with windows zip and extracted with 7zip are exactly the same (I used Beyond Compare to compare).
    Would be nice if MS would use shorter file and folder names, though ;).
Sign In or Register to comment.