Sales Credit Memo Applied Cost Issue..

David_CoxDavid_Cox Posts: 509Member
Hi Guys,
The Scenario is as follows..

All Items Average Costing..
Customer created a Sales Credit Memo (applied to a posted Sales Invoice)
Navigated and the Costs posted do not match the costs applied to the Original Sales Invoice
We created a revaluation journal and re-valued the Credit Memo items with the correct costs, these were adjusted fine.

Issue:
The credit memo items are applied to a new invoice but the Costs are not updated, the applied entries from the item ledger form do not show the entries closed by the credit memo, so the adjusted value is not hitting the C.O.G.s account, and the Invoice statistics are wrong.

Dynamics NAV 2009 SP1
Any Ideas?

David
Analyst Developer with over 17 years Navision, Contract Status - Busy
Mobile: +44(0)7854 842801
Email: [email protected]
Twitter: https://twitter.com/Adeptris
Website: http://www.adeptris.com

Comments

  • Alex_ChowAlex_Chow Posts: 5,063Member
    May be obvious, but have you ran the adjust cost - item entries process?
  • golfergolfer Posts: 69Member
    Probably a long shot, but check if the Posting Date differs from the Valuation date on the value entry of the inbound item ledger entry.
  • David_CoxDavid_Cox Posts: 509Member
    hi Guys,
    Adjust Cost and post was run, and the dates are exactly the same! :cry:

    It looks like the application Credit Memo to Invoice does not update the costs correctly.

    Regards

    David
    Analyst Developer with over 17 years Navision, Contract Status - Busy
    Mobile: +44(0)7854 842801
    Email: [email protected]
    Twitter: https://twitter.com/Adeptris
    Website: http://www.adeptris.com
  • Alex_ChowAlex_Chow Posts: 5,063Member
    Sorry, I misread.

    Yes, when you post a credit, it's an increase to inventory so the unit cost will come from the Unit Cost (LCY) field on the sales lines.
  • golfergolfer Posts: 69Member
    I remember some issues when revaluating credit memo transactions, but as I understood this was the part that was OK. That would then mean the cost is/would not be the same as sales line on the Credit Memo. Having run the adjust batch does not neccesarily mean the transaction is actually adjusted, can you verify that? As I mentioned in a post the other day there is a KB on PartnerSource explaning the adjust costing and the consequences in different scenarios and considering the settings for allowed posting dates in General Ledger Setup and User Setup.

    viewtopic.php?f=23&t=57765
  • David_CoxDavid_Cox Posts: 509Member
    Hi All,
    All posting dates are open no periods closed, what I have found investigating this Topic.

    Purchase and Sales Orders were created as Drop Shipment with some wrong data which were posted to Invoice stage.
    Credit Memo created copy document and the same Posing Date (4th April) applied to the Invoice this was then posted.

    So we have positive stock entries created from the Credit Memo, so far so good at this point the costs all match.

    New Sales Invoice was created same date (4th April) and consumed the stock entries created by the Credit Memo, however the customer uses the Average Costing method, and the new Sales Invoice costs were uplifted to the Item Average Cost and variances posted to the G/L

    The “Item Application Entry” (Table 339) was created mapping the two ledger entries but the flag “Cost Application” is left un-checked and the “Value Entry” (Table 5802) is flagged “Valued By Average Cost” and adjustment entries created, from the Sales Item Ledger Entry form Applied Entries do not return the applied (Credit Memo) Item Ledger Entry from the application table.

    With high value products this variation is around 200k distorting (reducing) the reported profits margin on the Sales Invoices.

    Regards

    David ](*,)
    Analyst Developer with over 17 years Navision, Contract Status - Busy
    Mobile: +44(0)7854 842801
    Email: [email protected]
    Twitter: https://twitter.com/Adeptris
    Website: http://www.adeptris.com
  • andrewlai0930andrewlai0930 Posts: 1Member
    David_Cox wrote: »
    Hi All,
    All posting dates are open no periods closed, what I have found investigating this Topic.

    Purchase and Sales Orders were created as Drop Shipment with some wrong data which were posted to Invoice stage.
    Credit Memo created copy document and the same Posing Date (4th April) applied to the Invoice this was then posted.

    So we have positive stock entries created from the Credit Memo, so far so good at this point the costs all match.

    New Sales Invoice was created same date (4th April) and consumed the stock entries created by the Credit Memo, however the customer uses the Average Costing method, and the new Sales Invoice costs were uplifted to the Item Average Cost and variances posted to the G/L

    The “Item Application Entry” (Table 339) was created mapping the two ledger entries but the flag “Cost Application” is left un-checked and the “Value Entry” (Table 5802) is flagged “Valued By Average Cost” and adjustment entries created, from the Sales Item Ledger Entry form Applied Entries do not return the applied (Credit Memo) Item Ledger Entry from the application table.

    With high value products this variation is around 200k distorting (reducing) the reported profits margin on the Sales Invoices.

    Regards

    David ](*,)


    Hi David,

    We faced the same issue as you . However, may I know what do you mean by "rom the Sales Item Ledger Entry form Applied Entries do not return the applied (Credit Memo) Item Ledger Entry from the application table."?

    Thank you

    Andrew
Sign In or Register to comment.