NAV Autoincrement property not working in Connector

jwilderjwilder York, MaineMember Posts: 263
edited 2013-03-15 in Dynamics CRM
Does the Connector support using a table with a primary key of Entry No. which has autoincrement = true.

We are getting the following error:
[Contact to NAV CRM Contact] has encountered an error while processing key Nate Boyd, 1335117f-d58c-e211-9301-00155d015a02. You cannot change the value of an AutoIncrement field. Field: Entry No. Table: CRM Contacts Identification fields and values: Entry No.='139659'

This is a CRM to NAV map. We did not set the Entry No. in the map and we tried setting the Entry No. to zero. Both give an error. Any thoughts on how to make this work (besides turning AutoIncrement off and writing code on the OnInsert trigger)
Jason Wilder
[email protected]

Comments

  • jwilderjwilder York, MaineMember Posts: 263
    A little more research shows that even if I turn Autoincrement off and try to increase the Entry No. with code I get the same problem. The problem restate is this:
    On a CRM to NAV map it seems that the primary key on the NAV table cannot be an Entry No. (integer).

    Has anyone done this before?
    Jason Wilder
    [email protected]
  • StarkStark Member Posts: 39
    Hi,
    Are you pass particular value in Entry No. and still have an error?
    Trough Connector you should always pass particular value for primary Fields.
    http://nav-connector.com/ - blog about Dynamics Connector
  • jwilderjwilder York, MaineMember Posts: 263
    No value is passed. It is filled in with code in the OnInsert trigger in NAV.
    Jason Wilder
    [email protected]
Sign In or Register to comment.