Missing sp_sdidebug NAV 2009

TFCrowtherTFCrowther Member Posts: 35
edited 2009-02-19 in NAV Three Tier
Following Clausl's blog on how to debug the RTC, http://blogs.msdn.com/clausl/archive/2008/10/14/debugging-in-nav-2009.aspx

I've switched on the CustomSetting.config
<add key="EnableDebugging" value="true"></add>

However when attaching the process in Visual Studio 2008, Microsoft.Dynamics.Nav.Server.exe and opening the RTC client I get the following error:

Microsoft Dynamics NAV

The following SQL Server error or errors occurred:

2812,"42000",[Microsoft][ODBC SQL Server Driver][SQL Server]Could not find stored procedure 'sp_sdidebug'.
5703,"01000",[Microsoft][ODBC SQL Server Driver][SQL Server]Changed language setting to us_english.
0,"01000",[Microsoft][ODBC SQL Server Driver]SQL Debugging disabled
5701,"01000",[Microsoft][ODBC SQL Server Driver][SQL Server]Changed database context to 'master'.


I've not found a lot of helpful info searching google for the missing 'sp_sdidebug'.

Any suggestions.




  • dmccraedmccrae Member, Microsoft Employee Posts: 144
    When you attach the debugger to the NAV Server process, there is an button on the dialog to select the type of debugging support. I do not have my dev studio handy right now so can't recall the name of the button, but there are not many on that dialog.

    Selecting this brings up a windows where you can choose between Managed, Native, T-SQL. You need to uncheck the T-SQL option, then you will not need this debugging stored procedure.
    Dean McCrae - Senior Software Developer, NAV Server & Tools

    This posting is provided "AS IS" with no warranties, and confers no rights.
  • TFCrowtherTFCrowther Member Posts: 35
    Great thanks

    Yes you attach the process in Visual Studio

    Then click the select button - Attach To: Managed Code
Sign In or Register to comment.