[SOLVED]NAV CRM Integration error after upgrading CRM to 9 - metadata issue

TomigsTomigs Posts: 59Member
edited 2018-12-20 in NAV Three Tier
Hi,

Our customer in NAV2016 is natively integrated with Dynamics CRM (on-line), using the standard Dynamics NAV - CRM integration. Originally was connecting to Dynamics CRM 7.0.

During 2017, the Dynamics CRM was upgraded to version 8, so the integration stopped working (we started receiving a metadata error). We updated a few libraries (XRM) on the NAV service and client from the latest CRM SDK and the communication between both was re-stablished.

Recently Dynamics CRM has been upgraded to version 9, again resulting on the communication between NAV and CRM being broken. We have proceeded as before, downloading the latest CRM SDK and changing libraries on the Dynamics NAV folders (client and server).
However this time the metadata error persists (this time version 9). So we don't know if there is some file or configuration that we are missing upgrading, or we need to do something differently.

We have also proceeded to change the server settings (Windows Register) to use TLS1.2, just in case it was the cause of the issue, but the only result of that is a different error this time ("authentication error"). We can roll back these changes.

Can anyone give any suggestion on anything that we should be taking into account or possible fixes?

The steps given are essentially what described on this blog:
https://anandan-msft.blogspot.com/2017/02/how-to-make-nav-2016-crm-connector-work.html

Thanks.
Tomas

Answers

  • SuDSuD Posts: 95Member
    Tomigs wrote: »
    Hi,

    Our customer in NAV2016 is natively integrated with Dynamics CRM (on-line), using the standard Dynamics NAV - CRM integration. Originally was connecting to Dynamics CRM 7.0.

    During 2017, the Dynamics CRM was upgraded to version 8, so the integration stopped working (we started receiving a metadata error). We updated a few libraries (XRM) on the NAV service and client from the latest CRM SDK and the communication between both was re-stablished.

    Recently Dynamics CRM has been upgraded to version 9, again resulting on the communication between NAV and CRM being broken. We have proceeded as before, downloading the latest CRM SDK and changing libraries on the Dynamics NAV folders (client and server).
    However this time the metadata error persists (this time version 9). So we don't know if there is some file or configuration that we are missing upgrading, or we need to do something differently.

    We have also proceeded to change the server settings (Windows Register) to use TLS1.2, just in case it was the cause of the issue, but the only result of that is a different error this time ("authentication error"). We can roll back these changes.

    Can anyone give any suggestion on anything that we should be taking into account or possible fixes?

    The steps given are essentially what described on this blog:
    https://anandan-msft.blogspot.com/2017/02/how-to-make-nav-2016-crm-connector-work.html

    Thanks.
    Tomas

    Trying this with NAV inbuilt connector or with MS Dynamics connector for NAV ?

    Recommend to use inbuilt connector if NAV version is 2016.
  • TomigsTomigs Posts: 59Member
    Hi Sud,

    Thanks for the answer. I'm using the standard, inbuilt integration, not the connector.

    The NAV version is 2016, build 46621. I wonder if the later builds would be adapted to connect to CRM 9.


    edcg6ize7bst.jpg



    Tomas
  • SuDSuD Posts: 95Member
    Hi Tom,

    have you gone through this below link.
    https://community.dynamics.com/crm/f/117/t/219620
  • TomigsTomigs Posts: 59Member
    Hi Sud,

    Thanks for the link. No I had not seen that.

    Essentially what I have done is substituting the Microsoft.XRM.DLL library (and others) on the NAV executables. I got the new libraries by extracting a Nuget package downloaded from the CRM 9 SDK, on this link:
    https://docs.microsoft.com/en-us/dynamics365/customer-engagement/developer/download-dynamics-365-sdk-v9

    I don't know if I'm understanding the link correctly (as my .NET knowledge is very limited): are they suggesting that extracting the DLLs from the nugget file is not enough? Should I be opening the libraries with a certain version of .NET/Visual Studio and recompile them?

    In parallel what I'm trying to do is to do a test upgrading NAV2016 to the latest cumulative update (CU38) and re-test (not there yet because of technical issues).

    Regards,
    Tomas
  • TomigsTomigs Posts: 59Member
    Hi again,

    We have finally resolved the connection: we have partially upgraded NAV to the last cumulative update (CU38):

    * We have upgraded then NAV engine (executables): that way the XRM/ CRM libraries have been upgraded
    * Importantly, we have also upgraded NAV objects, but only the ones related to the NAV/CRM integration (*@crm*).

    More info here:
    https://blogs.msdn.microsoft.com/nav/2017/03/10/microsoft-dynamics-crm-2016-integration-on-premises-and-online-with-microsoft-dynamics-nav-2016-2017/

    Regards,
    Tomas
Sign In or Register to comment.