Options

NAS & JOB QUEUE

nromainnromain Member Posts: 57
Hi all,

i have a really really strange issue using Job queue via NAS on a 5.00 SQL database. I explain :

We want to automatically run report 499 everyday. So we add test on GUIALLOWED before all dialog vars and we setup the job queue, restart the NAS and we have the error "You cannot use C/AL variable of type DIALOG blablabla..."

So, i decide to launch NAS in debug mode to see where we forget to put the "IF GUIALLOWED THEN". I deactivate Job queue, reinitialize the job queue task and enter in the DOS prompt to launch the nas with debug. Debugguer starts correctly, i deactivate breakpoints on triggers and then, the debugguer doesn't find any error. but when i open the database and see in the job queue log, i see always the same error "You cannot use C/AL variable of type DIALOG blablabla..." But the NAS debugguer is still running and no error encountered !

So, i stop everything, restup the job queue task, reopen the dos prompt and launch the NAS with debug but then i decide to follow the code line by line and the strange thing happens. It is as if the NAS only active the job queue but not manage the tasks. In the job queue log, always the same error but my debugguer not even enter into the report!! It was as if the task was done on another session. Strange!

Do you have any idea? an explanation?

Thank you so much and pardon my poor english ;)

Best regards,

Nicolas ROMAIN

Comments

  • Options
    rhpntrhpnt Member Posts: 688
    Did you disable the request form on that report?

    I never used NAS in debugger mode but when used with Job Queue I always make a copy of the object to run and modify it for NAS usage (delete all dialog variables, any code reference to those vars,disable the request form,...) so a clean version of the object is used. Always worked for me.
Sign In or Register to comment.