NAS - freezes on processing oofice automation

rixrixrixrix Posts: 121Member
Did someone of you encountered such problem ?

I have one job runned by jub scheduler wich does some oofice things (using dbolewrap.ocx)

A) When I run it as normal user - everything is OK.
B) When I am logged to win server with NAS credentials and run NAS from command line - everything is OK
C) But when NAS is runned as service, the task freezes as "Processing"

And I dunno what happened ....
And can't debug it, because of B)

Thank you

P.S. It frreezes on this function .. it is very first function using OLE wrapper....
OW.CreateObjectByName (pvOoClass, '')

? Does OOfice needed to be run under "real logged" user ??? or something ?


  • bbrownbbrown Posts: 3,013Member
    Microsoft does not support runnign Office automation in this manner. However this mayhelp you out.
    There are no bugs - only undocumented features.
  • rixrixrixrix Posts: 121Member
    Finally I found the problem / solution

    After 1 day trying everything a found out that problem is with "first time registration wizard" of open office.
    I didin't even think about it because I ran the wizard logged as user used by "service" so I thought everything is fine.

    But it wasnt. It seems that service doesn't use all profile info of user and oo dinn't know that wizard was already ran.

    What helped was applying small code which disabled wizard for all users
    Downloaded here: ... ion_Wizard

    Thank you
  • rixrixrixrix Posts: 121Member
    So ... I am sorry but there are problems again :-(

    It works just on one NAS and not always ...
    On other NASes we have it doesn't work at all
  • rixrixrixrix Posts: 121Member
    So finally solved :)

    1. Add -headless -nofirsttimestartwizard options to all LocalServer32 keys in the registry which are used to identify what to run for ServiceManager Object
    2. After using OOfice functions you have to destroy Desktop Object, because restarting NAS causet to freeze it when dbolewrapper tries to run soffice.exe next time

    Everything works now
Sign In or Register to comment.