Metadata Issue, Object of type Page not found.

aavioaavio Posts: 176Member
edited 2012-06-25 in NAV Three Tier
Dear all,

i am stuck with an issue with Metadata.
i am trying to create Sales Order through web services. And after create i call for automatic BOM Item explode.
Most the case i am getting exception from BOM explode code
as
Metadata for object of type Page with id 27006562 is in a failed state. This is caused by a previous exception: Object of type Page with id 27006562 could not be found.

as it says page id 27006562 doesnt exist in my db, i checked and no other object have referencees to this page.
i have no idea why its refering to such a page.

please giude me.

thank you
aav!o

Answers

  • udayrmerudayrmer Posts: 171Member
    Please Compile & save this page
    Uday Mer | MS Dynamics NAV Techno-Functional Consultant
  • aavioaavio Posts: 176Member
    Dear udayrmer,

    but the page id 27006562 doesnt exist in my db. :(
    aav!o
  • mohana_cse06mohana_cse06 Posts: 4,850Member
  • pawanppawanp Posts: 90Member
    If you have added any new function in either form/page make sure Function ID should be same on page and form.
  • Troubles_In_ParadiseTroubles_In_Paradise Posts: 588Member
    I'm not sure that this could help you btw..
    I've seen this behaviour also with reports when renaming them from an ID to another.
    To solve this issue I search in the Object Metadata table records related to Old Id and New Id and I delete them.
    After that I compile the report (in this way the Object Metadata is created) and problem is solved.
    It seems it remains something "dirty" in the Object Metadata table.
    ~Rik~
    It works as expected... More or Less...
  • Troubles_In_ParadiseTroubles_In_Paradise Posts: 588Member
    sorry double post
    ~Rik~
    It works as expected... More or Less...
  • aavioaavio Posts: 176Member
    hi guyz i solved it.

    within Coding, there was code to run form
    FORM.RUNMODAL(....)
    
    when executed same code called from webservice, it somehow refering to page object of same ID as form. :roll:
    i am not sure why its so :shock:

    i just skiped executing the FORM.RUNMODAL when called from webservice. :D

    thanks everyone for your valuable input.
    From this issue i understood that for all Metadata issues, just compiling objects will not solve the issue. :) :D
    aav!o
Sign In or Register to comment.