Nav Web Services and Sharepoint on the same app server

Dan77Dan77 Posts: 17Member
edited 2012-05-12 in NAV Three Tier
Hi guys,

this is not a question, but just a quick topic for those who would have to deal with such a problem, as it might be helpful to others.

In case you have both Nav Web Services and Sharepoint foundation installed on the same application server, have decent secure domain account setup for all your services, Service Principal Names and Kerberos trust for delegation rules set up as well, and are struggling to expose Nav WS to the outer world, you might be in this situation:


Sharepoint working fine for all clients. In localhost, Nav WS are working fine.

Unexpected behavior when trying to access your [url=http://server:port/DynamicsNAV/WS]http://server:port/DynamicsNAV/WS[/url], with recurrent Windows login dialog and HTTP 400 - Bad request each and every time.

No NT AUTHORITY\ANONYMOUS LOGON msg in the back-end.


This is an Internet Explorer problem: it does not address HTTP SPN with the port (use Wireshark to analyze Kerberos messages and see the SPN used), unless you apply the following hotfix to all clients registries:

http://support.microsoft.com/kb/908209

Post-hotfix installation instructions

Note These steps should be applied on the client computer on which you try to open the Web page.

After you install the hotfix, you must add the
FEATURE_INCLUDE_PORT_IN_SPN_KB908209
registry key, and then set its DWORD value to iexplore.exe. To do this, follow these steps.
For 32-bit computers

Click Start, click Run, type regedit, and then click OK.
In the left pane, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
On the Edit menu, point to New, and then click Key.
Type FEATURE_INCLUDE_PORT_IN_SPN_KB908209, and then press ENTER.
On the Edit menu, point to New, and then click DWORD Value.
Type iexplore.exe, and then press ENTER.
On the Edit menu, click Modify.
Type 1 in the Value data box, and then click OK.
Exit Registry Editor.

For 64-bit computers

Click Start, click Run, type regedit, and then click OK.
In the left pane, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\Main\FeatureControl
On the Edit menu, point to New, and then click Key.
Type FEATURE_INCLUDE_PORT_IN_SPN_KB908209, and then press ENTER.
On the Edit menu, point to New, and then click DWORD Value.
Type iexplore.exe, and then press ENTER.
On the Edit menu, click Modify.
Type 1 in the Value data box, and then click OK.
Exit Registry Editor.


Note that the hotfix is indicated to apply to IE 6 but the post-hotfix install steps are also applying to IE 7, 8 and 9 at this time.
Sign In or Register to comment.